Your message dated Tue, 04 Feb 2020 20:44:18 +0000
with message-id <e1iz53s-000f5a...@fasolo.debian.org>
and subject line Bug#950389: fixed in glibc 2.29-10
has caused the Debian Bug report #950389,
regarding libcrypt1: failure to switch from libc6 to libcrypt1 hoses the whole 
system
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
950389: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=950389
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libcrypt1
Version: 1:4.4.10-5
Severity: critical
Justification: breaks the whole system

I’ve did a “sudo apt-get --purge dist-upgrade” and ended with,
see screenshot below.

Thankfully, I had a root session in a chroot open and used
the program, statically linked, from http://koltsoff.com/pub/getroot/
to recover access outside the chroot, by using dpkg -i --force-all
first on libc6_*.deb, then libcrypt1_*.deb. Afterwards, normal recovery
mechanisms apply.

Log:

Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  fonts-noto-hinted fonts-noto-ui-core liblouis19 libxml-simple-perl
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  libpcre2-posix0*
The following NEW packages will be installed:
  fonts-cantarell libcrypt1:i386 libcrypt1:amd64 libcrypt1 libcrypt1-dev:i386 
libcrypt1-dev liblouis20
  libpcre2-posix2 libxstring-perl linux-image-5.3.0-3-amd64:amd64
The following packages have been kept back:
  libegl1 libgl1 libgles2 libglvnd0 libglx0 librsvg2-2:i386 libselinux1:i386 
libv4l-0:i386 libv4lconvert0:i386
  libvirt-clients libvirt-daemon libvirt-daemon-system libvirt0 python3-libvirt 
tomcat9
The following packages will be upgraded:
  bochsbios debhelper debianutils drkonqi dwz fig2dev fonts-comfortaa git 
git-doc git-man gitk gitweb glibc-doc
  gstreamer1.0-alsa:i386 gstreamer1.0-alsa gstreamer1.0-libav:i386 
gstreamer1.0-plugins-bad:i386
  gstreamer1.0-plugins-base gstreamer1.0-plugins-base:i386 
gstreamer1.0-plugins-good:i386
  gstreamer1.0-plugins-ugly:i386 intel-microcode:amd64 iptables kde-spectacle 
kinit kio kwalletmanager
  libbrlapi0.7 libc-bin libc-dev-bin libc-l10n libc6:i386 libc6 libc6:amd64 
libc6-dbg libc6-dev:i386 libc6-dev
  libdbus-glib-1-2:i386 libdbus-glib-1-2 libdebhelper-perl 
libgstreamer-plugins-bad1.0-0:i386
  libgstreamer-plugins-base1.0-0:i386 libgstreamer-plugins-base1.0-0 
libgstreamer1.0-0:i386 libgstreamer1.0-0
  libhttp-cookies-perl libio-pty-perl libip4tc2 libip6tc2 libiptc0 
libjs-bootstrap4 libjs-popper.js
  libjs-sphinxdoc libkaccounts1 libkf5activities5 libkf5bookmarks5 
libkf5completion5 libkf5configwidgets5
  libkf5crash5 libkf5declarative5 libkf5globalaccel-bin libkf5globalaccel5 
libkf5globalaccelprivate5
  libkf5iconthemes5 libkf5jobwidgets5 libkf5kcmutils5 libkf5khtml5 
libkf5kiocore5 libkf5kiontlm5
  libkf5kiowidgets5 libkf5kipi32.0.0 libkf5kirigami2-5 libkf5newstuff5 
libkf5newstuffcore5 libkf5notifications5
  libkf5parts5 libkf5purpose-bin libkf5purpose5 libkf5quickaddons5 
libkf5textwidgets5 libkf5wallet-bin
  libkf5wallet5 libkwalletbackend5-5 liblinux-epoll-perl liblist-someutils-perl 
liblouis-bin liblouis-data
  liblouisutdml-bin liblouisutdml-data liblouisutdml9 libmime-lite-perl 
libmoox-late-perl libmysofa0:i386
  libmysofa0 libokular5core8 libpcre2-16-0 libpcre2-32-0 libpcre2-8-0:i386 
libpcre2-8-0 libpcre2-dev
  libqmobipocket2 libsepol1 libsepol1-dev libserd-0-0:i386 libserd-0-0 
libslirp0 libsnappy1v5:i386 libsnappy1v5
  libsord-0-0:i386 libsord-0-0 libspecio-perl libsratom-0-0:i386 libsratom-0-0 
libtype-tiny-perl libvncclient1
  libvncserver1 libwireshark-data libwmf0.2-7 libx265-179:i386 libx265-179 
libxtables12 libz3-4:i386
  linux-image-amd64:amd64 linux-libc-dev linux-libc-dev:i386 locales 
locales-all netbase node-glob okular
  python3-requests python3-urllib3 qml-module-org-kde-kcm 
qml-module-org-kde-kirigami2
  qml-module-org-kde-kquickcontrolsaddons systemsettings tcpdump texlive 
texlive-base texlive-bibtex-extra
  texlive-extra-utils texlive-font-utils texlive-fonts-extra 
texlive-fonts-extra-doc texlive-fonts-extra-links
  texlive-fonts-recommended texlive-fonts-recommended-doc texlive-formats-extra 
texlive-full texlive-games
  texlive-humanities texlive-humanities-doc texlive-lang-arabic 
texlive-lang-chinese texlive-lang-cjk
  texlive-lang-cyrillic texlive-lang-czechslovak texlive-lang-english 
texlive-lang-european texlive-lang-french
  texlive-lang-german texlive-lang-greek texlive-lang-italian 
texlive-lang-korean texlive-lang-other
  texlive-lang-polish texlive-lang-portuguese texlive-lang-spanish 
texlive-latex-base texlive-latex-base-doc
  texlive-latex-extra texlive-latex-extra-doc texlive-latex-recommended 
texlive-latex-recommended-doc
  texlive-luatex texlive-metapost texlive-metapost-doc texlive-music 
texlive-pictures texlive-pictures-doc
  texlive-plain-generic texlive-pstricks texlive-pstricks-doc 
texlive-publishers texlive-publishers-doc
  texlive-science texlive-science-doc texlive-xetex
188 upgraded, 10 newly installed, 1 to remove and 15 not upgraded.
Need to get 2756 MB of archives.
After this operation, 306 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://deb.debian.org/debian-ports unstable/main x32 debianutils x32 
4.9.1 [100 kB]
Get:2 http://deb.debian.org/debian sid/main amd64 libcrypt1 amd64 1:4.4.10-5 
[84.8 kB]
[…]
Get:198 http://deb.debian.org/debian sid/main i386 texlive-full all 
2019.20191208-4 [33.2 kB]
Fetched 2756 MB in 15min 12s (3023 kB/s)
/etc/etckeeper/commit.d/50vcs-commit[22]: ${@#-m}: bad substitution
warning: etckeeper failed to commit changes in /etc using git
apt-listchanges: Reading changelogs...
apt-listchanges: Mailing t...@bsikolab.tarent.de: apt-listchanges: news for 
tglase.lan.tarent.de
apt-listchanges: Mailing t...@bsikolab.tarent.de: apt-listchanges: changelogs 
for tglase.lan.tarent.de
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 396608 files and directories currently installed.)
Preparing to unpack .../debianutils_4.9.1_x32.deb ...
Unpacking debianutils (4.9.1) over (4.9) ...
Setting up debianutils (4.9.1) ...
(Reading database ... 396608 files and directories currently installed.)
Preparing to unpack .../0-libc6_2.29-6_x32.deb ...
De-configuring libc6:i386 (2.29-3) ...
De-configuring libc6:amd64 (2.29-3) ...
Unpacking libc6:x32 (2.29-6) over (2.29-3) ...
Preparing to unpack .../1-libc6_2.29-6_amd64.deb ...
/usr/bin/perl: error while loading shared libraries: libcrypt.so.1: cannot open 
shared object file: No such file or directory
dpkg: error processing archive 
/tmp/apt-dpkg-install-vKsDE7/1-libc6_2.29-6_amd64.deb (--unpack):
 new libc6:amd64 package pre-installation script subprocess returned error exit 
status 127
Preparing to unpack .../2-libc6_2.29-6_i386.deb ...
De-configuring libc6:amd64 (2.29-3) ...
/usr/bin/perl: error while loading shared libraries: libcrypt.so.1: cannot open 
shared object file: No such file or directory
dpkg: error processing archive 
/tmp/apt-dpkg-install-vKsDE7/2-libc6_2.29-6_i386.deb (--unpack):
 new libc6:i386 package pre-installation script subprocess returned error exit 
status 127
Selecting previously unselected package libcrypt1:amd64.
dpkg: regarding .../3-libcrypt1_1%3a4.4.10-5_amd64.deb containing 
libcrypt1:amd64:
 libcrypt1:amd64 breaks libc6 (<< 2.29-4)
  libc6:amd64 (version 2.29-3) is present and installed.
  libc6:i386 (version 2.29-3) is present and installed.

dpkg: error processing archive 
/tmp/apt-dpkg-install-vKsDE7/3-libcrypt1_1%3a4.4.10-5_amd64.deb (--unpack):
 installing libcrypt1:amd64 would break existing software
Selecting previously unselected package libcrypt1:x32.
dpkg: regarding .../4-libcrypt1_1%3a4.4.10-5_x32.deb containing libcrypt1:x32:
 libcrypt1 breaks libc6 (<< 2.29-4)
  libc6:amd64 (version 2.29-3) is present and installed.
  libc6:i386 (version 2.29-3) is present and installed.

dpkg: error processing archive 
/tmp/apt-dpkg-install-vKsDE7/4-libcrypt1_1%3a4.4.10-5_x32.deb (--unpack):
 installing libcrypt1:x32 would break existing software
Selecting previously unselected package libcrypt1:i386.
dpkg: regarding .../5-libcrypt1_1%3a4.4.10-5_i386.deb containing libcrypt1:i386:
 libcrypt1:i386 breaks libc6 (<< 2.29-4)
  libc6:amd64 (version 2.29-3) is present and installed.
  libc6:i386 (version 2.29-3) is present and installed.

dpkg: error processing archive 
/tmp/apt-dpkg-install-vKsDE7/5-libcrypt1_1%3a4.4.10-5_i386.deb (--unpack):
 installing libcrypt1:i386 would break existing software
Errors were encountered while processing:
 /tmp/apt-dpkg-install-vKsDE7/1-libc6_2.29-6_amd64.deb
 /tmp/apt-dpkg-install-vKsDE7/2-libc6_2.29-6_i386.deb
 /tmp/apt-dpkg-install-vKsDE7/3-libcrypt1_1%3a4.4.10-5_amd64.deb
 /tmp/apt-dpkg-install-vKsDE7/4-libcrypt1_1%3a4.4.10-5_x32.deb
 /tmp/apt-dpkg-install-vKsDE7/5-libcrypt1_1%3a4.4.10-5_i386.deb
perl: error while loading shared libraries: libcrypt.so.1: cannot open shared 
object file: No such file or directory
E: Sub-process /usr/bin/dpkg returned an error code (1)



-- System Information:
Debian Release: bullseye/sid
  APT prefers unreleased
  APT policy: (500, 'unreleased'), (500, 'buildd-unstable'), (500, 'unstable'), 
(100, 'experimental')
Architecture: x32 (x86_64)
Foreign Architectures: i386, amd64

Kernel: Linux 5.2.0-3-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_FIRMWARE_WORKAROUND
Locale: LANG=C, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=C (charmap=UTF-8)
Shell: /bin/sh linked to /bin/lksh
Init: sysvinit (via /sbin/init)

--- End Message ---
--- Begin Message ---
Source: glibc
Source-Version: 2.29-10

We believe that the bug you reported is fixed in the latest version of
glibc, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 950...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Aurelien Jarno <aure...@debian.org> (supplier of updated glibc package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 04 Feb 2020 20:37:26 +0100
Source: glibc
Architecture: source
Version: 2.29-10
Distribution: unstable
Urgency: medium
Maintainer: GNU Libc Maintainers <debian-glibc@lists.debian.org>
Changed-By: Aurelien Jarno <aure...@debian.org>
Closes: 946599 950389
Changes:
 glibc (2.29-10) unstable; urgency=medium
 .
   * debian/debhelper.in/libc.{preinst,postrm}: Remove fallback to dpkg
     --print-architecture for pre-multiarch systems.
   * debian/debhelper.in/libc.preinst: fallback to text output in case
     perl debconf is used and perl is not usable.  Closes: #946599, #950389.
   * debian/patches/git-updates.diff: update from upstream stable branch.
Checksums-Sha1:
 d61faeac8d5822e35195c73b4bcbebd19d4b8346 8739 glibc_2.29-10.dsc
 cd6643d22f0bae8fefb9739e576f5db0f180f696 868696 glibc_2.29-10.debian.tar.xz
 edbd48a2726ce369893809d6212c1afdc5035a6f 7763 glibc_2.29-10_source.buildinfo
Checksums-Sha256:
 4365adda24264fd57faabafd0429a5f123635790fc6391d8abc2ecc15072f2b3 8739 
glibc_2.29-10.dsc
 d66ef632e204670b237b8f1a9e76e1aa9e7d5fc96d271f33128a10474740ea62 868696 
glibc_2.29-10.debian.tar.xz
 ce967535a6577186b521335a0fba06a97a0a6e096997297af4fdda134e77aa8a 7763 
glibc_2.29-10_source.buildinfo
Files:
 b5d0587c8d19387f86bba0337e2b284c 8739 libs required glibc_2.29-10.dsc
 bedc735e647a3dce401b4a27908b991b 868696 libs required 
glibc_2.29-10.debian.tar.xz
 f235628b42d0b84843bb632995bba7b5 7763 libs required 
glibc_2.29-10_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEUryGlb40+QrX1Ay4E4jA+JnoM2sFAl45yI0ACgkQE4jA+Jno
M2sTYA//ZTneUaPfDsFycUcr7g+o7z8poNtiHObu4ZdJLo3tgVHor3B7l8m5hF7i
D++eFbRGcbpBrHe0vn7Ofjn9nhkDiWQNd0oVxtE8w79Q8oNGdQHRxRnock+Oy0Ig
XxMAl0KznZED6oenbcm23aGTfp31Odhj+tXCNXVFHIemMD0AlcczpvoqR27FaZwn
zbkJg2Zi335b8vSDqrS2Cq6N7hB8gY7VbtnYgotf85WwyaCDXvx3+8z0qlC6q/SL
oYUUMekDd2/irURm1XaVXW3PL7mi6bIpLaNtHoHMxXlt9ULwR01AzRKAXe26FKYk
B/jqsKo/JDc+rMF7vTDlY4xke2sE59zc37hV76uMGUY+WIZ3xd+x8Uz+YhjYYCFM
fAzRMre8vpZUcyV8EDErT/n3+uQpouEkVhI1sm5+eKs7UuW1wq3LuImqeSX3k9PD
DGRqidUIgw5TTgDwLYSKPy5q4fk+aaJIyFBE7ucUow8iWldPVEadtF0pnks1L3SV
JjB790Rs1lynPt/BwtW5mDSLNS2ze6NKpBOF5/Sf+QrVuroPk02zSbWIEJYvl87P
UzRUjd5rtHtBi5sT6pTtTRFAnRUhmEJzJ5HnwTcV/ssYdrMUVMkRdo/7QEymtjCl
AyBKTDJd07M8eE6Y86hMTc4qMeMY4RS6AqCQwZPx6H4joJ4YQd4=
=L9GV
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to