Hello, I have a depending problem. For clearly understanding I will write
whole story. So I added a *buster-backports* repository with *main*,
*contrib*, *non-free*. I run "sudo aptitude update", then "sudo aptitude
upgrade (dist-upgrade also)" I get a many upgrades and for my drivers and
firmwares, but there is a one problem I cant upgrade my libvulkan1,
nvidia-settings, libxnvctrl0 packages becouse of unmet depends, so here is
more info:

sudo aptitude dist-upgrade

The following packages will be upgraded:
 *libvulkan1{b} libvulkan1:i386{b} libxnvctrl0 nvidia-settings{b}*
4 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,165 kB of archives. After unpacking 7,168 B will be used.
The following packages have unmet dependencies:
 *libvulkan1* : Depends: *libc6* (>= 2.29) but 2.28-10 is installed
 *libvulkan1:i386* : Depends: *libc6:i386* (>= 2.29) but 2.28-10 is
 *nvidia-settings* : Depends: *screen-resolution-extra* (>= 0.18~) which is
a virtual package and is not provided by any available package

                   Depends: libc6 (>= 2.29) but 2.28-10 is installed
open: 34; closed: 628; defer: 8; conflict: 8

So how you can see that there is a problem with libc6, libc6:i386, and

Reply via email to