Package: locales
Version: 2.28-10
Severity: minor
Tags: l10n

Hi,

I upgraded yesterday to Buster and in the process of upgrading packages I got
the following perl warning in several packages:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "es_ES.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").


In some places I have found "a way to fix it", but this not works for me. I
followed the steps.

export LANGUAGE=es_ES.UTF-8
export LANG=es_ES.UTF-8
export LC_ALL=es_ES.UTF-8
locale-gen
dpkg-reconfigure locales


selecting the generation of all locales and to use es_ES.UTF-8 in the debconf
window. But the problem persists.
Also I have tried to change to another locales, like

en_US.UTF-8

but LANGUAGE and LC_ALL keep unset. Coming back to my original locale does not
fix the problem.

I do not know whether this can be related with bugs:

#687522
#724456


I can make test, send log files,... to find what is causing this problem.

Thank you for your great work !!

Sincerely,
Jose









-- System Information:
Debian Release: 10.4
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.19.0-9-amd64 (SMP w/8 CPU cores)
Kernel taint flags: TAINT_PROPRIETARY_MODULE, TAINT_FIRMWARE_WORKAROUND, 
TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=es_ES.utf8, LC_CTYPE=es_ES.utf8 (charmap=UTF-8), 
LANGUAGE=es_ES.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages locales depends on:
ii  debconf [debconf-2.0]  1.5.71
ii  libc-bin               2.28-10
ii  libc-l10n              2.28-10

locales recommends no packages.

locales suggests no packages.

-- debconf information:
* locales/locales_to_be_generated: All locales
* locales/default_environment_locale: es_ES.UTF-8

Reply via email to