I've had some time to experiment on Debian GNU/Hurd and I tried to set up a 
murmurd (Mumble Server).

Since the required zeroc-ice libraries can't be built at the moment, I tried to 
build murmurd from the current Mumble Git and these options to qmake:

qmake -recursive main.pro CONFIG+=no-client CONFIG+=no-ice

This way a murmurd binary gets build, but it can't bind to the IPv4 socket, I 
tried serveral combinations with different ports and different IPs.

root@hurd:~/mumble/release# ./murmurd -fg -ini ./murmur.ini
<W>2013-09-18 23:38:59.170 Initializing settings from 
/root/mumble/release/murmur.ini (basepath /root/mumble/release)
<W>2013-09-18 23:38:59.170 Binding to address
<W>2013-09-18 23:38:59.170 OpenSSL: OpenSSL 1.0.1e 11 Feb 2013
<C>2013-09-18 23:38:59.170 WARNING: You are running murmurd as root, without 
setting a uname in the ini file. This might be a security risk.
<W>2013-09-18 23:39:00.410 ServerDB: Opened SQLite database 
<W>2013-09-18 23:39:00.420 Murmur 1.2.5 (Compiled Sep 18 2013 23:28:18) running 
on X11: GNU 0.3: Booting servers
<W>2013-09-18 23:39:00.450 1 => Server: TCP Listen on failed: 
Unknown error
<W>2013-09-18 23:39:00.460 1 => Stopped

I investigated this further and found out that socket(2, 4194305, 0) is 
returning errno = 1073741865 which is ESPIPE?!

This causes the Qt code to return "Unknown error" to the Mumble-Code.


I think that translates to socket(AF_INET, SOCK_STREAM | SOCK_CLOEXEC, 0)

Any ideas why this is happening?

Mit freundlichen Grüßen
Jens Mühlenhoff

To UNSUBSCRIBE, email to debian-hurd-requ...@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmas...@lists.debian.org
Archive: http://lists.debian.org/523a3d6c.2030...@gmx.de

Reply via email to