Whoever handles this (Zumbi?) might want to hold off on making
linux-image-686-pae in jessie-backports
==
linux-image-4.7.0-0.bpo.1-686-pae-unsigned (or similar)

I run nginx caches on Debian Jessie which I keep up to date
with backports kernels. I saw the 4.7 above, so I tried it, but
I've started seeing a bunch of eth0 errors since then on x86:
https://dl.dropboxusercontent.com/u/14570328/if_err_eth0-4.7.png

I have not seen this on our 64-bit systems running 4.7, but
these have far larger RAM and perhaps less pressure on it.

I'm also getting OOMs which did not previously
happen AFAIK, e.g. http://pastebin.com/SFErSKGS

These are small VMs under heavy memory pressure.
I believe RAM is often fragmented, which makes me think the memory compaction issue mentioned here may be it:
https://lkml.org/lkml/2016/8/22/184

I cannot say for sure that this is the problem. Still,
eth0 errors seem to have vanished once I reverted to 4.6.

I have vm.min_free_kbytes = 8192 and I would test
to see if removing that helps, but I have a flight to catch. :-)

nginx is also set up to use aio write and threads, not sendfile
(it's serving over HTTPS) and tcp_nopush/tcp_nodelay.

Best regards,
--
Laurence "GreenReaper" Parry - Inkbunny administrator
greenreaper.co.uk - wikifur.com - flayrah.com - inkbunny.net
"Eternity lies ahead of us, and behind. Have you drunk your fill?"

Reply via email to