Package: libcpupower-dev
Version: 4.7.5-1
Severity: wishlist
Tags: stretch


Please make libcpupower-dev depend on libcpupower1 (= ${binary:Version}),
like it's usually done with all the other -dev packages.

Currently it's possible to install libcpupower-dev but leave libcpupower1
not installed. It leads to FTBFS of mate-applets when building it with
libcpupower instead of libcpufreq (using B-D:libcpupower-dev instead of
libcpufreq-dev, and "--with-cpufreq-lib=cpupower" build flag). The linker
shows an error message ("/usr/bin/ld: cannot find -lcpupower") and the build
breaks. Installing libcpupower1 manually fixes the problem.

CC'ing MATE Packaging Team just in case - if there will possibly be a migration
of mate-applets to libcpupower someday, this issue will get in the way.

Reply via email to