I installed a Thinkpad T60 last year around 16.19.2016 with Debian Testing.
With the kernel contained at that time suspend to disk was working well.
(linux-image-4.6.0-1-686-pae  4.6.4-1, [1])

Just recently I got this system back and upgraded it to current Stretch.
(linux-image-4.9.0-3-686-pae  4.9.30-2+deb9u3)
There I can confirm resume is not working anymore.

As my first attempt to add some information to this bug report never
arrived (with reportbug) I decided to try with a vanilla kernel:
The git head from yesterday has the same issue (4.13.0-rc4+)

And then tried some git bisect.
Finally I came to this commit:

        $ git bisect bad
        65fe935dd2387a4faf15314c73f5e6d31ef0217e is the first bad commit
        commit 65fe935dd2387a4faf15314c73f5e6d31ef0217e
        Author: Kees Cook <keesc...@chromium.org>
        Date:   Mon Jun 13 15:10:02 2016 -0700

            x86/KASLR, x86/power: Remove x86 hibernation restrictions
            With the following fix:
            70595b479ce1 ("x86/power/64: Fix crash whan the hibernation code 
passes control to the image kernel")
            ... there is no longer a problem with hibernation resuming a
            KASLR-booted kernel image, so remove the restriction.

        :040000 040000 62ec80a77951d45d01880a17fc64e9ee9d2e974c 
a43a4a4e1d1625a67d5403328d52a0103253a747 M      Documentation
        :040000 040000 81718df2254545796eda792b975f9ab32d2a62bd 
b75ddf9403921b170727f685370ecc70d0ff6907 M      arch
        :040000 040000 85ea5ad6e9b8fea1691552d14c998b04f8364136 
3462d929255d999a68f1a37e7e7ba9a66b099a39 M      kernel

I tried adding "nokaslr" to my default kernel parameters and
indeed I could successfully resume with a vanilla 4.13.0-rc4+ and
the default Stretch 4.9.30-2+deb9u3 kernels.

Adding this to /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="quiet nokaslr"
and executing
should make it permanent.

Probably this can be confirmed by Sergio B.?

Kind regards,


Reply via email to