Package: linux-headers-amd64
Version: 6.1.27-1~bpo11+1
Severity: important

Dear Maintainer,

It seems that linux-headers-amd64 package (6.1.27-1~bpo11+1) from
bullseye-backports cannot be installed.  Because it depends on
linux-headers-6.1.0-0.deb11.9-amd64 (= 6.1.27-1~bpo11+1), which is not

As a consequence, DKMS modules are not built after an upgrade. Therefore
hardware devices depending on DKMS modules will not work anymore.

Steps to reproduce, starting with a fresh install of

  * add the following APT source in /etc/apt/sources.list:
    deb bullseye-backports main contrib non-free"
  * apt update
  * apt install -t bullseye-backports linux-image-amd64
    -> ok: kernel 6.1 is successfully installed
  * apt install -r bullseye-backports linux-headers-amd64
    -> not ok: installation fails with the following message:

  Some packages could not be installed. This may mean that you have
  requested an impossible situation or if you are using the unstable
  distribution that some required packages have not yet been created
  or been moved out of Incoming.
  The following information may help to resolve the situation:
  The following packages have unmet dependencies:
   linux-headers-amd64 : Depends: linux-headers-6.1.0-0.deb11.9-amd64 (= 
6.1.27-1~bpo11+1) but it is not installable
  E: Unable to correct problems, you have held broken packages.

I'm not totally sure it is actually a bug, please excuse me if I did something



-- System Information:
Debian Release: 11.7
  APT prefers oldstable-updates
  APT policy: (500, 'oldstable-updates'), (500, 'oldstable-security'), (500, 
Architecture: amd64 (x86_64)

Kernel: Linux 5.10.0-25-amd64 (SMP w/2 CPU threads)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8), LANGUAGE not set
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages linux-headers-amd64 depends on:
pn  linux-headers-5.10.0-22-amd64        <none>
pn  linux-headers-5.10.0-25-amd64        <none>
pn  linux-headers-6.1.0-0.deb11.9-amd64  <none>

linux-headers-amd64 recommends no packages.

linux-headers-amd64 suggests no packages.

Reply via email to