This is an automated email from the git hooks/post-receive script.

nthykier pushed a commit to branch master
in repository lintian.

commit f42a3257e8d7a76fc6faf5462d15422158f94904
Author: Niels Thykier <ni...@thykier.net>
Date:   Sun Oct 16 15:45:24 2016 +0000

    d/debhelper/compat-level: Bump deprecated value
    
    Signed-off-by: Niels Thykier <ni...@thykier.net>
---
 data/debhelper/compat-level                                           | 2 +-
 debian/changelog                                                      | 3 +++
 t/tests/cruft-empty-diff/debian/debian/compat                         | 2 +-
 t/tests/cruft-empty-diff/upstream/debian/compat                       | 2 +-
 t/tests/debhelper-compat-old/desc                                     | 2 +-
 .../lintian-include-dir/profiles/lintian-test/main.profile            | 2 ++
 .../vendors/lintian-test/main/data/debhelper/compat-level             | 3 +++
 t/tests/debhelper-compat-whitespace/debian/debian/compat              | 1 -
 t/tests/debhelper-compat-whitespace/debian/debian/compat.in           | 1 +
 t/tests/debhelper-dh-clean-k-deprecated/debian/debian/compat          | 1 -
 t/tests/debhelper-dh-compat/debian/debian/rules                       | 4 ++--
 t/tests/debhelper-dh-compat/desc                                      | 1 +
 .../lintian-include-dir/profiles/lintian-test/main.profile            | 2 ++
 .../vendors/lintian-test/main/data/debhelper/compat-level             | 3 +++
 t/tests/debhelper-dh-compat/tags                                      | 2 +-
 t/tests/debhelper-executable-files/tags                               | 1 +
 t/tests/debhelper-lacks-versioned-deps/debian/debian/compat           | 2 +-
 t/tests/debhelper-lacks-versioned-deps/tags                           | 3 +--
 t/tests/files-python-general/tags                                     | 1 +
 t/tests/generic-dh-make-2005/tags                                     | 1 +
 t/tests/generic-dh-make-2008/tags                                     | 2 +-
 t/tests/legacy-debconf/tags                                           | 1 +
 t/tests/legacy-debug/tags                                             | 1 +
 t/tests/legacy-libbaz/tags                                            | 1 +
 24 files changed, 31 insertions(+), 13 deletions(-)

diff --git a/data/debhelper/compat-level b/data/debhelper/compat-level
index cc01235..50006a3 100644
--- a/data/debhelper/compat-level
+++ b/data/debhelper/compat-level
@@ -3,7 +3,7 @@ pedantic=9
 # warn (pedantic) if does not depend on this debhelper level
 recommended=9
 # warn if below this level
-deprecated=5
+deprecated=9
 # warn if equal or above
 experimental=11
 
diff --git a/debian/changelog b/debian/changelog
index 5b3ddbe..4fce0cf 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,9 @@ lintian (2.5.49) UNRELEASED; urgency=medium
 
   * data/cruft/non-distributable-files:
     + [BR] Add some rapidjson files.
+  * data/debhelper/compat-level:
+    + [NT] Bump the deprecated debhelper compat level to match the one
+      in debhelper.
   * data/files/privacy-breaker-tag-attr:
     + [BR] Apply patch from Frederic Bonnard detecting audio tags.
       (Closes: #840009)
diff --git a/t/tests/cruft-empty-diff/debian/debian/compat 
b/t/tests/cruft-empty-diff/debian/debian/compat
index 7f8f011..ec63514 100644
--- a/t/tests/cruft-empty-diff/debian/debian/compat
+++ b/t/tests/cruft-empty-diff/debian/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/t/tests/cruft-empty-diff/upstream/debian/compat 
b/t/tests/cruft-empty-diff/upstream/debian/compat
index 7f8f011..ec63514 100644
--- a/t/tests/cruft-empty-diff/upstream/debian/compat
+++ b/t/tests/cruft-empty-diff/upstream/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/t/tests/debhelper-compat-old/desc 
b/t/tests/debhelper-compat-old/desc
index df4cf81..d40efaa 100644
--- a/t/tests/debhelper-compat-old/desc
+++ b/t/tests/debhelper-compat-old/desc
@@ -3,7 +3,7 @@ Version: 1.0
 Description: Test for old debian/compat file
 Skeleton: pedantic
 Options: --pedantic -I -E -L +classification
-Test-Depends: debhelper (>= 9),
+Profile: lintian-test
 Test-For:
  package-uses-old-debhelper-compat-version
  debian-build-system
diff --git 
a/t/tests/debhelper-compat-old/lintian-include-dir/profiles/lintian-test/main.profile
 
b/t/tests/debhelper-compat-old/lintian-include-dir/profiles/lintian-test/main.profile
new file mode 100644
index 0000000..f0e27cf
--- /dev/null
+++ 
b/t/tests/debhelper-compat-old/lintian-include-dir/profiles/lintian-test/main.profile
@@ -0,0 +1,2 @@
+Profile: lintian-test/main
+Extends: debian/main
diff --git 
a/t/tests/debhelper-compat-old/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
 
b/t/tests/debhelper-compat-old/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
new file mode 100644
index 0000000..d4a0049
--- /dev/null
+++ 
b/t/tests/debhelper-compat-old/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
@@ -0,0 +1,3 @@
+@include-parent
+deprecated=1
+recommened=100
diff --git a/t/tests/debhelper-compat-whitespace/debian/debian/compat 
b/t/tests/debhelper-compat-whitespace/debian/debian/compat
deleted file mode 100644
index b8ab780..0000000
--- a/t/tests/debhelper-compat-whitespace/debian/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-       7  
diff --git a/t/tests/debhelper-compat-whitespace/debian/debian/compat.in 
b/t/tests/debhelper-compat-whitespace/debian/debian/compat.in
new file mode 100644
index 0000000..ce49772
--- /dev/null
+++ b/t/tests/debhelper-compat-whitespace/debian/debian/compat.in
@@ -0,0 +1 @@
+       {$dh_compat_level}  
diff --git a/t/tests/debhelper-dh-clean-k-deprecated/debian/debian/compat 
b/t/tests/debhelper-dh-clean-k-deprecated/debian/debian/compat
deleted file mode 100644
index 7f8f011..0000000
--- a/t/tests/debhelper-dh-clean-k-deprecated/debian/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-7
diff --git a/t/tests/debhelper-dh-compat/debian/debian/rules 
b/t/tests/debhelper-dh-compat/debian/debian/rules
index 260f917..111f495 100755
--- a/t/tests/debhelper-dh-compat/debian/debian/rules
+++ b/t/tests/debhelper-dh-compat/debian/debian/rules
@@ -1,8 +1,8 @@
 #!/usr/bin/make -f
 
-export DH_COMPAT=7
+export DH_COMPAT=10
 
 %:
        dh $@
 
-DH_COMPAT=5
+DH_COMPAT=8
diff --git a/t/tests/debhelper-dh-compat/desc b/t/tests/debhelper-dh-compat/desc
index 0f6e052..c75eb8e 100644
--- a/t/tests/debhelper-dh-compat/desc
+++ b/t/tests/debhelper-dh-compat/desc
@@ -1,6 +1,7 @@
 Testname: debhelper-dh-compat
 Version: 1.0
 Description: Test the value of DH_COMPAT
+Profile: lintian-test
 Test-For:
  debian-rules-sets-DH_COMPAT
  declares-possibly-conflicting-debhelper-compat-versions
diff --git 
a/t/tests/debhelper-dh-compat/lintian-include-dir/profiles/lintian-test/main.profile
 
b/t/tests/debhelper-dh-compat/lintian-include-dir/profiles/lintian-test/main.profile
new file mode 100644
index 0000000..f0e27cf
--- /dev/null
+++ 
b/t/tests/debhelper-dh-compat/lintian-include-dir/profiles/lintian-test/main.profile
@@ -0,0 +1,2 @@
+Profile: lintian-test/main
+Extends: debian/main
diff --git 
a/t/tests/debhelper-dh-compat/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
 
b/t/tests/debhelper-dh-compat/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
new file mode 100644
index 0000000..d4a0049
--- /dev/null
+++ 
b/t/tests/debhelper-dh-compat/lintian-include-dir/vendors/lintian-test/main/data/debhelper/compat-level
@@ -0,0 +1,3 @@
+@include-parent
+deprecated=1
+recommened=100
diff --git a/t/tests/debhelper-dh-compat/tags b/t/tests/debhelper-dh-compat/tags
index 57e0969..3256995 100644
--- a/t/tests/debhelper-dh-compat/tags
+++ b/t/tests/debhelper-dh-compat/tags
@@ -1,2 +1,2 @@
-E: debhelper-dh-compat source: 
declares-possibly-conflicting-debhelper-compat-versions rules=5 compat=9
+E: debhelper-dh-compat source: 
declares-possibly-conflicting-debhelper-compat-versions rules=8 compat=9
 W: debhelper-dh-compat source: debian-rules-sets-DH_COMPAT line 3
diff --git a/t/tests/debhelper-executable-files/tags 
b/t/tests/debhelper-executable-files/tags
index 62bdd41..f7c1cf6 100644
--- a/t/tests/debhelper-executable-files/tags
+++ b/t/tests/debhelper-executable-files/tags
@@ -2,3 +2,4 @@ W: debhelper-executable-files source: 
package-file-is-executable debian/changelo
 W: debhelper-executable-files source: package-file-is-executable debian/control
 W: debhelper-executable-files source: package-file-is-executable 
debian/copyright
 W: debhelper-executable-files source: package-file-is-executable 
debian/manpages
+W: debhelper-executable-files source: 
package-uses-deprecated-debhelper-compat-version 8
diff --git a/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat 
b/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat
index 7f8f011..ec63514 100644
--- a/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat
+++ b/t/tests/debhelper-lacks-versioned-deps/debian/debian/compat
@@ -1 +1 @@
-7
+9
diff --git a/t/tests/debhelper-lacks-versioned-deps/tags 
b/t/tests/debhelper-lacks-versioned-deps/tags
index ae66544..be16bc9 100644
--- a/t/tests/debhelper-lacks-versioned-deps/tags
+++ b/t/tests/debhelper-lacks-versioned-deps/tags
@@ -1,2 +1 @@
-P: debhelper-lacks-versioned-deps source: 
package-lacks-versioned-build-depends-on-debhelper 7
-P: debhelper-lacks-versioned-deps source: 
package-uses-old-debhelper-compat-version 7
+P: debhelper-lacks-versioned-deps source: 
package-lacks-versioned-build-depends-on-debhelper 9
diff --git a/t/tests/files-python-general/tags 
b/t/tests/files-python-general/tags
index efc9189..007df84 100644
--- a/t/tests/files-python-general/tags
+++ b/t/tests/files-python-general/tags
@@ -2,5 +2,6 @@ E: python-kinterbasdb: package-installs-python-bytecode 
usr/share/python-kinterb
 E: python-kinterbasdb: package-installs-python-bytecode 
usr/share/python-kinterbasdb/code.pyo
 E: python-kinterbasdb: package-installs-python-egg 
usr/share/python-kinterbasdb/python.egg
 E: python-kinterbasdb: package-installs-python-pycache-dir 
usr/share/python-kinterbasdb/__pycache__/
+W: files-python-general source: 
package-uses-deprecated-debhelper-compat-version 7
 W: python-kinterbasdb-dbg: python-debug-in-wrong-location 
usr/lib/debug/usr/lib/pyshared/python2.7/python-module.so 
usr/lib/debug/usr/lib/pymodules/python2.7/python-module.so
 W: python-kinterbasdb: file-should-not-be-compressed 
usr/share/doc/python-kinterbasdb/docs/objects.inv.gz
diff --git a/t/tests/generic-dh-make-2005/tags 
b/t/tests/generic-dh-make-2005/tags
index 06f948c..febf0fa 100644
--- a/t/tests/generic-dh-make-2005/tags
+++ b/t/tests/generic-dh-make-2005/tags
@@ -9,6 +9,7 @@ W: generic-dh-make-2005 source: 
debian-rules-ignores-make-clean-error line 47
 W: generic-dh-make-2005 source: debian-rules-missing-recommended-target 
build-arch
 W: generic-dh-make-2005 source: debian-rules-missing-recommended-target 
build-indep
 W: generic-dh-make-2005 source: dh-clean-k-is-deprecated
+W: generic-dh-make-2005 source: 
package-uses-deprecated-debhelper-compat-version 5
 W: generic-dh-make-2005: copyright-without-copyright-notice
 W: generic-dh-make-2005: new-package-should-close-itp-bug
 W: generic-dh-make-2005: readme-debian-contains-debmake-template
diff --git a/t/tests/generic-dh-make-2008/tags 
b/t/tests/generic-dh-make-2008/tags
index d6d28ec..b60de1a 100644
--- a/t/tests/generic-dh-make-2008/tags
+++ b/t/tests/generic-dh-make-2008/tags
@@ -8,7 +8,6 @@ I: generic-dh-make-2008: 
extended-description-is-probably-too-short
 I: generic-dh-make-2008: package-contains-empty-directory usr/bin/
 I: generic-dh-make-2008: package-contains-empty-directory usr/sbin/
 P: generic-dh-make-2008 source: no-dep5-copyright
-P: generic-dh-make-2008 source: package-uses-old-debhelper-compat-version 7
 P: generic-dh-make-2008: copyright-with-old-dh-make-debian-copyright
 P: generic-dh-make-2008: no-upstream-changelog
 W: generic-dh-make-2008 source: ancient-standards-version 3.7.3 (current is 
CURRENT)
@@ -33,6 +32,7 @@ W: generic-dh-make-2008 source: dh-make-template-in-source 
debian/postrm.ex
 W: generic-dh-make-2008 source: dh-make-template-in-source debian/preinst.ex
 W: generic-dh-make-2008 source: dh-make-template-in-source debian/prerm.ex
 W: generic-dh-make-2008 source: dh-make-template-in-source debian/watch.ex
+W: generic-dh-make-2008 source: 
package-uses-deprecated-debhelper-compat-version 7
 W: generic-dh-make-2008 source: superfluous-clutter-in-homepage <insert the 
upstream URL, if relevant>
 W: generic-dh-make-2008: bad-homepage <insert the upstream URL, if relevant>
 W: generic-dh-make-2008: copyright-has-url-from-dh_make-boilerplate
diff --git a/t/tests/legacy-debconf/tags b/t/tests/legacy-debconf/tags
index e3af05d..00ec375 100644
--- a/t/tests/legacy-debconf/tags
+++ b/t/tests/legacy-debconf/tags
@@ -43,6 +43,7 @@ W: debconf source: maintainer-script-lacks-debhelper-token 
debian/debconf-test.p
 W: debconf source: misnamed-po-file debian/po/lang.po
 W: debconf source: misnamed-po-file debian/po/sample-file.po
 W: debconf source: newer-debconf-templates
+W: debconf source: package-uses-deprecated-debhelper-compat-version 5
 W: debconf source: patch-system-but-no-source-readme
 W: debconf source: stray-translated-debconf-templates debconf-test.templates.de
 W: debconf source: template-uses-unsplit-choices debconf-test - 
debconf/testmulti-escape
diff --git a/t/tests/legacy-debug/tags b/t/tests/legacy-debug/tags
index b17c195..f7e7567 100644
--- a/t/tests/legacy-debug/tags
+++ b/t/tests/legacy-debug/tags
@@ -27,6 +27,7 @@ W: debug source: dbg-package-missing-depends libhello0-dbg
 W: debug source: debhelper-but-no-misc-depends hello-hello-dbg
 W: debug source: debhelper-but-no-misc-depends hi-dbg
 W: debug source: dh-clean-k-is-deprecated
+W: debug source: package-uses-deprecated-debhelper-compat-version 5
 W: debug source: timewarp-standards-version (2006-04-04 < 2006-04-26)
 W: hello-dbg: debug-file-with-no-debug-symbols usr/lib/debug/usr/bin/hello
 W: hello-hello-dbg: latest-debian-changelog-entry-without-new-version
diff --git a/t/tests/legacy-libbaz/tags b/t/tests/legacy-libbaz/tags
index 3010321..8e6c45e 100644
--- a/t/tests/legacy-libbaz/tags
+++ b/t/tests/legacy-libbaz/tags
@@ -44,6 +44,7 @@ W: libbaz source: debhelper-but-no-misc-depends libbaz2
 W: libbaz source: debhelper-but-no-misc-depends libbaz2-dbg
 W: libbaz source: debhelper-but-no-misc-depends libbaz2-dev
 W: libbaz source: native-package-with-dash-version
+W: libbaz source: package-uses-deprecated-debhelper-compat-version 6
 W: libbaz source: source-nmu-has-incorrect-version-number 1-1
 W: libbaz source: substvar-source-version-is-deprecated libbaz2-dev
 W: libbaz1-dev: wrong-section-according-to-package-name libbaz1-dev => libdevel

-- 
Alioth's /usr/local/bin/git-commit-notice on 
/srv/git.debian.org/git/lintian/lintian.git

Reply via email to