Package: lintian
Version: 2.5.48
Severity: normal


with a package with very old upstream files, I got the following
lintian error-level tags since converting the package to debhelper and
source format "3.0 (quilt)" -- where I of course removed all patches
touching files which get updated via the implicit dh_autoreconf call

E: ccze source: ancient-autotools-helper-file config.guess 2002-07-09
N:    The referenced file has a time stamp older than year 2004 and the
N:    package does not build-depend on autotools-dev or automake and therefore
N:    apparently does not update it. This usually means that the source
N:    package will not build correctly on all currently released
N:    architectures.
N:    For packages using debhelper, the tools from the dh-autoreconf package
N:    should handle this issue. cdbs will automatically update these files if
N:    autotools-dev is installed during build, but the build dependency on
N:    autotools-dev is still necessary.
N:    Otherwise, read /usr/share/doc/autotools-dev/README.Debian.gz (from the
N:    autotools-dev package) for information on how to fix this problem.
N:    Severity: important, Certainty: possible
N:    Check: cruft, Type: source
E: ccze source: ancient-autotools-helper-file config.sub 2002-07-03

If I add an explicit dh-autoreconf buil-dependency, these errors
vanish. But the dependency on "debhelper (>= 10)" and debian/compat =
10 already imply that.

So this smells a lot like a false positive to me. (I'd though
appreciate some confirmation before I start trying to make up a patch
for this. :-)

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (980, 'unstable-debug'), (600, 'testing'), 
(111, 'buildd-unstable'), (111, 'buildd-experimental'), (110, 'experimental'), 
(105, 'experimental-debug')
Architecture: amd64 (x86_64)

Kernel: Linux 4.8.0-rc5-amd64 (SMP w/4 CPU cores)
Locale: LANG=C.UTF-8, LC_CTYPE=C.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lintian depends on:
ii  binutils                          2.27-8
ii  bzip2                             1.0.6-8
ii  diffstat                          1.61-1
ii  file                              1:5.28-4
ii  gettext                 
ii  intltool-debian                   0.35.0+20060710.4
ii  libapt-pkg-perl                   0.1.29+b6
ii  libarchive-zip-perl               1.59-1
ii  libclass-accessor-perl            0.34-1
ii  libclone-perl                     0.38-2+b1
ii  libdigest-sha-perl                5.96-1+b1
ii  libdpkg-perl                      1.18.10
ii  libemail-valid-perl               1.202-1
ii  libfile-basedir-perl              0.07-1
ii  libipc-run-perl                   0.94-1
ii  liblist-moreutils-perl            0.416-1+b1
ii  libparse-debianchangelog-perl     1.2.0-11
ii  libperl5.24 [libdigest-sha-perl]  5.24.1~rc3-3
ii  libtext-levenshtein-perl          0.13-1
ii  libtimedate-perl                  2.3000-2
ii  liburi-perl                       1.71-1
ii  libyaml-libyaml-perl              0.63-1+b1
ii  man-db                            2.7.5-1
ii  patchutils                        0.3.4-1
ii  perl                              5.24.1~rc3-3
ii  t1utils                           1.39-2
ii  xz-utils                          5.2.2-1.2

Versions of packages lintian recommends:
ii  dpkg                                 1.18.10
ii  libautodie-perl                      2.29-2
ii  libperlio-gzip-perl                  0.19-1+b2
ii  perl                                 5.24.1~rc3-3
ii  perl-modules-5.24 [libautodie-perl]  5.24.1~rc3-3

Versions of packages lintian suggests:
ii  binutils-multiarch     2.27-8
ii  dpkg-dev               1.18.10
ii  libhtml-parser-perl    3.72-2+b1
ii  libtext-template-perl  1.46-1

-- no debconf information

Reply via email to