Package: lintian
Version: 2.5.50.4
Severity: wishlist
Tags: patch

Dear maintainer,

Could you relax a little the regexp that looks into d/changelog in order
to decide wether or not the new-package-should-not-package-python2-module
tag should be fired up?

Essentially, I suggest removing the requirement to have a space between
"python" and "2".

Here is a rough patch. :)

Cheers!

-- 
PEB

-- System Information:
Debian Release: 9.4
  APT prefers stable
  APT policy: (990, 'stable'), (99, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-3-amd64 (SMP w/8 CPU cores)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL 
set to fr_FR.UTF-8), LANGUAGE=fr_FR.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set 
to fr_FR.UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lintian depends on:
ii  binutils                          2.28-5
ii  bzip2                             1.0.6-8.1
ii  diffstat                          1.61-1+b1
ii  file                              1:5.30-1+deb9u1
ii  gettext                           0.19.8.1-2
ii  intltool-debian                   0.35.0+20060710.4
ii  libapt-pkg-perl                   0.1.32
ii  libarchive-zip-perl               1.59-1
ii  libclass-accessor-perl            0.34-1
ii  libclone-perl                     0.38-2+b1
ii  libdpkg-perl                      1.18.24
ii  libemail-valid-perl               1.202-1
ii  libfile-basedir-perl              0.07-1
ii  libipc-run-perl                   0.94-1
ii  liblist-moreutils-perl            0.416-1+b1
ii  libparse-debianchangelog-perl     1.2.0-12
ii  libperl5.24 [libdigest-sha-perl]  5.24.1-3+deb9u2
ii  libtext-levenshtein-perl          0.13-1
ii  libtimedate-perl                  2.3000-2
ii  liburi-perl                       1.71-1
ii  libyaml-libyaml-perl              0.63-2
ii  man-db                            2.7.6.1-2
ii  patchutils                        0.3.4-2
ii  perl                              5.24.1-3+deb9u2
ii  t1utils                           1.39-2
ii  xz-utils                          5.2.2-1.2+b1

Versions of packages lintian recommends:
ii  dpkg                                 1.18.24
ii  libperlio-gzip-perl                  0.19-1+b2
ii  perl                                 5.24.1-3+deb9u2
ii  perl-modules-5.24 [libautodie-perl]  5.24.1-3+deb9u2

Versions of packages lintian suggests:
ii  binutils-multiarch     2.28-5
ii  dpkg-dev               1.18.24
ii  libhtml-parser-perl    3.72-3
ii  libtext-template-perl  1.46-1

-- no debconf information
diff --git a/checks/python.pm b/checks/python.pm
index f24152ffa..ec671c874 100644
--- a/checks/python.pm
+++ b/checks/python.pm
@@ -127,7 +127,7 @@ sub _run_binary {
         and none { $pkg =~ /$_$/ } @IGNORE
         and @entries == 1
         and $entries[0]->Changes
-        !~ /\bpython 2(?:\.x)? (?:variant|version)\b/im
+        !~ /\bpython ?2(?:\.x)? (?:variant|version)\b/im
         and index($entries[0]->Changes, $pkg) == -1) {
         tag 'new-package-should-not-package-python2-module', $pkg;
     }

Reply via email to