Your message dated Wed, 13 Jun 2018 19:49:30 +0000
with message-id <e1ftblq-000cnl...@fasolo.debian.org>
and subject line Bug#833608: fixed in lintian 2.5.90
has caused the Debian Bug report #833608,
regarding lintian: version-substvar-for-external-package, but external package 
is versioned provides
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
833608: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=833608
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: lintian
Version: 2.5.45
Severity: normal

In trying to simplify the APT build system, I changed the library package
libapt-pkg5.0 and libapt-inst2.0 to provide a versionless-name:

  Package: libapt-pkg5.0
  Provides: libapt-pkg (= ${binary:Version})

So I can depend on it like this:

  Package: libapt-pkg-dev
  Depends: libapt-pkg (= ${binary:Version})

This however leads to a version-substvar-for-external-package error
from lintian, as it does not understand that the package name is a
versioned provides.

We previously had a substvar that ${libapt-pkg-name}, but I wanted
to get rid of substvars as far as possible, as that involves non-declarative
stuff in rules.

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (900, 'unstable'), (500, 'unstable-debug'), (500, 'testing'), 
(500, 'stable'), (100, 'experimental'), (1, 'experimental-debug')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.6.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_IE.UTF-8, LC_CTYPE=en_IE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /usr/bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages lintian depends on:
ii  binutils                          2.26.1-1
ii  bzip2                             1.0.6-8
ii  diffstat                          1.61-1
ii  file                              1:5.28-4
ii  gettext                           0.19.8.1-1
ii  hardening-includes                2.8+nmu2
ii  intltool-debian                   0.35.0+20060710.4
ii  libapt-pkg-perl                   0.1.29+b5
ii  libarchive-zip-perl               1.58-1
ii  libclass-accessor-perl            0.34-1
ii  libclone-perl                     0.38-2
ii  libdata-alias-perl                1.20-1+b1
ii  libdpkg-perl                      1.18.10
ii  libemail-valid-perl               1.200-1
ii  libfile-basedir-perl              0.07-1
ii  libipc-run-perl                   0.94-1
ii  liblist-moreutils-perl            0.416-1
ii  libparse-debianchangelog-perl     1.2.0-10
ii  libperl5.22 [libdigest-sha-perl]  5.22.2-3
ii  libtext-levenshtein-perl          0.13-1
ii  libtimedate-perl                  2.3000-2
ii  liburi-perl                       1.71-1
ii  libyaml-libyaml-perl              0.41-6+b1
ii  man-db                            2.7.5-1
ii  patchutils                        0.3.4-1
ii  perl                              5.22.2-3
ii  t1utils                           1.39-2
ii  xz-utils                          5.1.1alpha+20120614-2.1

Versions of packages lintian recommends:
ii  dpkg                                 1.18.10
pn  libperlio-gzip-perl                  <none>
ii  perl                                 5.22.2-3
ii  perl-modules-5.22 [libautodie-perl]  5.22.2-3

Versions of packages lintian suggests:
ii  binutils-multiarch     2.26.1-1
ii  dpkg-dev               1.18.10
ii  libhtml-parser-perl    3.72-2
ii  libtext-template-perl  1.46-1

-- Configuration Files:
/etc/lintianrc changed [not included]

-- no debconf information

-- 
Debian Developer - deb.li/jak | jak-linux.org - free software dev

When replying, only quote what is necessary, and write each reply
directly below the part(s) it pertains to (`inline'). Thank you.

--- End Message ---
--- Begin Message ---
Source: lintian
Source-Version: 2.5.90

We believe that the bug you reported is fixed in the latest version of
lintian, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 833...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Chris Lamb <la...@debian.org> (supplier of updated lintian package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Wed, 13 Jun 2018 18:58:43 +0000
Source: lintian
Binary: lintian
Architecture: source all
Version: 2.5.90
Distribution: unstable
Urgency: medium
Maintainer: Debian Lintian Maintainers <lintian-ma...@debian.org>
Changed-By: Chris Lamb <la...@debian.org>
Description:
 lintian    - Debian package checker
Closes: 833608 898809 900268 900670 901228
Changes:
 lintian (2.5.90) unstable; urgency=medium
 .
   * checks/binaries.pm:
     + [CL] Ignore .debuginfo files under /usr/lib/jvm to prevent false-
       positives in shared-lib-without-dependency-information.
       (Closes: #900268)
   * checks/cruft.pm:
     + [BR] Ignore HTML bold tags (eg. <b>) during license checking.
   * checks/fields.{desc,pm}:
     + [CL] Move invalid-version-number-for-derivative to a "source" type
       check so we have access to $info->native to prevent false-positives
       when checking derivative versions.
   * checks/systemd.pm:
     + [CL] Don't use potentially-undefined value in invalid .service files.
   * checks/version-substvars.pm:
     + [CL] Fix a false-positives in version-substvar-for-external-package
       when the "external" package is actually a "Provides" in the current
       source package.  (Closes: #833608)
 .
   * data/*:
     + [CL] Update and expand the documentation of
       derivative-{changed-by,versions} to match the implementation.
   * data/fields/obsolete-packages:
     + [BR] Detect obsolete Adobe Flash packages.
   * data/files/js-libraries:
     + [BR] Detect libjs-jquery-ui, a set of user interface interactions,
       effects, widgets, and themes built on top of the jQuery Javascript
       library.
   * data/scripts/interpreters:
     + [CL] Avoid #!/usr/bin/r false-positives when checking the
       missing-dep-for-interpreter tag as r-cran-littler also "Provides"
       this package.  (Closes: #901228)
   * data/spelling/corrections:
     + [PW] Add a number of corrections.
   * data/spelling/corrections-multiword:
     + [CL] Drop "some system" from the list of multiword spelling
       corrections.  (Closes: #900670)
 .
   * helpers/coll/objdump-info-helper:
     + [CL] Ignore low ASCII characters in ELF headers such as RPATH and
       SONAME to avoid false-positives in, for example, Go libraries.
       (Closes: #898809)
 .
   * vendors/pureos/main/data/fields/derivative-fields:
     + [CL] Update the Vcs-* checks for PureOS now that repo structure has
       introduced sub-groups.
Checksums-Sha1:
 78af6ff42444e223f48299d77ec604bd4dd42ea5 3511 lintian_2.5.90.dsc
 a67fc38628e90405248cf6e545af89e8d4ac72ca 1564448 lintian_2.5.90.tar.xz
 602e96e33c586ece3c0df4b240dc57d6e857b470 1123816 lintian_2.5.90_all.deb
 5a2bef3db0c6a04a180072948ef3149e02518f50 16171 lintian_2.5.90_amd64.buildinfo
Checksums-Sha256:
 f8447a0fd3924cceb00dae20bdfb1aaba62f5b8ddd132c2cad82a9a00c7f94e8 3511 
lintian_2.5.90.dsc
 df4a055123fa153a0179a2f9831ae9f60afd59872a87000980ee187d03dddb49 1564448 
lintian_2.5.90.tar.xz
 35ca892f3fd2c998eb60d7431c431c280babc9c687333bdf12a07bf0af72e519 1123816 
lintian_2.5.90_all.deb
 337c39aea311913dbad205a379b0ed5e8ca6d76959015d83afa29b763bf89bce 16171 
lintian_2.5.90_amd64.buildinfo
Files:
 fe1232b1b4e5b50f098aa8a4d87e45be 3511 devel optional lintian_2.5.90.dsc
 5d6d3fb0db0f01b05e282535eef11cb3 1564448 devel optional lintian_2.5.90.tar.xz
 ce531eff9533599e03fea35d787f65a7 1123816 devel optional lintian_2.5.90_all.deb
 ac5bc9f5a81da4d665839d14af39de44 16171 devel optional 
lintian_2.5.90_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEwv5L0nHBObhsUz5GHpU+J9QxHlgFAlshcaMACgkQHpU+J9Qx
HljAmw//TRLOiEWaW+WqHpnAq6HZMbzwGZACB1OTHoFegT2XUVxCHF+98NPCjh3S
8efhNTzqbmWggEcocYL24GGOiWj0m7drVAHja5IHDuY2US5kIoXuCnAk1AtzrAn2
4zZIJ+dX2emAUPItWyEwpshTN0OYZehY1lyP3iM6Qqj6FWKaA8a8JV4qY8Ffhv/u
qpORHJaLdzq4K2Kl8WVZL8QXucatA6cFF16FY5Z8bb7FuyCGbDhY4KY0EkOs8Xya
itIxFnKHG1vc5SsawC9+zhOyHhiY+y7wpll6xBS/+mxtfEGse0trnQ4uuBi+OCwy
LW9zP/Do36hIaSXacZ0UnsvoJHBNunmxlbPCh1/u7t+pKGnTMDUG2ylrxF2uqvCP
ex1i3+OpkGnSnevOCsxBYnVCs9Ch1UMkVTcvOa33wGnZCY7N47jIoRyCUgY5KAJ7
otns+ubXstHMkSbOcWKdmu4STJAEt6KiGpqHOMUe5cHpLpf+DQeBRpYgEMviCsPd
TYVzDXgwa+21w78me0xMy0V2v0nKsNYZMEAGCTHHQLfRvRaPt+C8RxDFcnnBtFT2
FsInzIRFML8I9vY1r9nbrN1AJ1sf81OhMPS3zaNClVh+rQ3iN6JjDQ5oGlgZ65D3
jEmFGtkwvK6lgGXd5fQtBAwXzQMXnnNwBlPZfDE/uHG//U4iWck=
=Q3pO
-----END PGP SIGNATURE-----

--- End Message ---

Reply via email to