Il giorno ven 25 nov 2016 alle 17:56, Federico Bruni <f...@inventati.org> ha scritto:
There's one difference that I forgot to mention: I used to build an i686 image from an i686 virtual machine, while now I'm trying to build it from an amd64 container. I tried to change the architecture of the image to amd64 to see if that was the issue. It seems that it isn't.

Perhaps there's some conflict between systemd-nspawn - which is running the debian container where I execute live-build (as my host is running Fedora) - and live-build or better other debian components?


I confirm that this is the reason of the error.
I had to create a new virtual machine and then I launched lb successfully.

It's very unfortunate that live-build does not work if run within a container set up on a Fedora host. What could be wrong with it? I see that the kernel is shared, that is if I run `uname -a` in the debian guest I get the same kernel of fedora host. But I don't think that the kernel influences live-build, does it?



Reply via email to