Hi there,

this is _very_ long overdue, but here come the notes taken collectively during 
DebConf16's LSB BoF. I'll put the takeaways first.

# tl;dr

Given that the word about lsb not being granted anymore might not have spread 
enough, <odyx> will try to work towards producing an 'lsb-compat' package (see 
'C' proposal below), ideally to be uploaded to NEW in the next days.

# Gobby notes

## Short history

2002 - LSB 1.1 first package in Debian
2004 - Chris Lawrence <lawrencc> as maintainer
       LSB 2
2005 - LSB 3
2006 - LSB 3.1
2008 - LSB 3.2
2012 - Didier Raboud <odyx> becomes maintainer
       Starts merge from Ubuntu
       Left green [ OK ] blocks
       LSB 4.1
2013 - Lots of cleanup
       More merge from Ubuntu
2014 - Growing concerns about LSB in general
       DebConf14 BoF discussing LSB on the long-term
       Baseline was "want LSB? → Help LSB"
2015 - LSB 5 released, not adapted for Debian
       9.20150826 upload
       Dropping all non-mandatory LSB packages
       LSB is about binary compatibility
       Debian doesn't check that it satisfies LSB
       Debian wouldn't alter its packages to satisfy the LSB
       Debian is not LSB-certified (no-one is)
       It's therefore better to drop our pseudo-support instead of
       continuing to pretend we have correct support
2016 - Ubuntu notices EPSON still releases printer driver packages
       depending on the `lsb` package, and partially reverts the
       packages drop in a Stable Release Update (xenial 9.20160110ubuntu0.1)

## As Debian; what do we do about that ?
* There are packages out there that continue to depend on lsb, or lsb-*
* We don't have a list.
* We know of:
 - epson-inkjet-printer-201106w (.deb converted from .rpm usig alien)
    Depends: lsb (>= 3.2)
 - google-earth depends on lsb-core, needs the ldconfig symlinks
 - FlexLM licensing software

* It is a user service question.

There are 3 options:
A) Nothing
     Try applying our levers on EPSON (and others)
     That was kinda the original plan; that the removal would bring
     awareness of the problem.
B) Ubuntu way
     Re-add lsb, lsb-printing and lsb-security to have
     epson-inkjet-printer-201106w be installable and runnable.

C) Debian way ?

New binary package:
     lsb-compat (9.20160728)
         Provides: lsb (= 4.1), lsb-printing (= 4.1), lsb-security (= 4.1),
                 lsb-core (= 4.1)
         Replaces: ^
         Depends: whatever was in lsb4.1 and that is needed by the above
                "known packages"
                (Added by Ubuntu: libjpeg62)
         Debian bug: #609882
- Release notes entry


D) Fix the LSB & provide the minimal subset of LSB 5

# Conclusions

The current maintainer <odyx> is uninterested to work on LSB 5 support, and 
uninterested by a full reintroduction of a subset of LSB packages. Unless 
someone else steps in, he'll try to produce a working lsb-compat package (see 
'C' proposal above), ideally uploaded to NEW before mid-october.

Reply via email to