Your message dated Sun, 15 Apr 2018 18:06:25 +0000
with message-id <e1f7m2j-0001dp...@fasolo.debian.org>
and subject line Bug#853557: fixed in morse-simulator 1.4-3
has caused the Debian Bug report #853557,
regarding morse-simulator FTBFS: ImportError: No module named 'version'
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
853557: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853557
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: morse-simulator
Version: 1.4-2
Severity: important
User: python-modules-t...@lists.alioth.debian.org
Usertags: sphinx1.5

Dear maintainer,

I am about to upload Sphinx 1.5 to unstable (it has been available in
experimental for several months now).

Your package fails to build with it:

  Running Sphinx v1.5.6
  making output directory...

  Exception occurred:
  Traceback (most recent call last):
    File "/usr/lib/python3/dist-packages/sphinx/cmdline.py", line 295, in main
      opts.warningiserror, opts.tags, opts.verbosity, opts.jobs)
    File "/usr/lib/python3/dist-packages/sphinx/application.py", line 163, in 
__init__
      confoverrides or {}, self.tags)
    File "/usr/lib/python3/dist-packages/sphinx/config.py", line 134, in 
__init__
      execfile_(filename, config)
    File "/usr/lib/python3/dist-packages/sphinx/util/pycompat.py", line 129, in 
execfile_
      exec_(code, _globals)
    File "conf.py", line 15, in <module>
  ImportError: No module named 'version'

The full build log is attached.

--
Dmitry Shachnev
 dpkg-buildpackage -rfakeroot -us -uc -j4
dpkg-buildpackage: warning: using a gain-root-command while being root
dpkg-buildpackage: info: source package morse-simulator
dpkg-buildpackage: info: source version 1.4-2
dpkg-buildpackage: info: source distribution unstable
dpkg-buildpackage: info: source changed by Sylvestre Ledru 
<sylves...@debian.org>
 dpkg-source --before-build morse-simulator-1.4
dpkg-buildpackage: info: host architecture amd64
 fakeroot debian/rules clean
dh clean --with python3
dh: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_testdir
   dh_auto_clean
dh_auto_clean: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_clean
dh_clean: Compatibility levels before 9 are deprecated (level 8 in use)
 dpkg-source -b morse-simulator-1.4
dpkg-source: info: using source format '3.0 (quilt)'
dpkg-source: info: building morse-simulator using existing 
./morse-simulator_1.4.orig.tar.gz
dpkg-source: info: building morse-simulator in 
morse-simulator_1.4-2.debian.tar.xz
dpkg-source: info: building morse-simulator in morse-simulator_1.4-2.dsc
 debian/rules build
dh build --with python3
dh: Compatibility levels before 9 are deprecated (level 8 in use)
   dh_testdir
   dh_update_autotools_config
   debian/rules override_dh_auto_configure
make[1]: Entering directory '/morse-simulator-1.4'
dh_auto_configure -- -DBUILD_DOC_SUPPORT=ON 
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
         -DCPACK_DEBIAN_PACKAGE_DEPENDS=python3-all-dev -DPYMORSE_SUPPORT=ON
dh_auto_configure: Compatibility levels before 9 are deprecated (level 8 in use)
        cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_VERBOSE_MAKEFILE=ON 
-DCMAKE_BUILD_TYPE=None -DCMAKE_INSTALL_SYSCONFDIR=/etc 
-DCMAKE_INSTALL_LOCALSTATEDIR=/var -DBUILD_DOC_SUPPORT=ON 
-DPYTHON_EXECUTABLE=/usr/bin/python3 
-DCPACK_DEBIAN_PACKAGE_DEPENDS=python3-all-dev -DPYMORSE_SUPPORT=ON
-- The C compiler identification is GNU 7.1.0
-- The CXX compiler identification is GNU 7.1.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.29") 
-- Found PythonInterp: /usr/bin/python3 (found suitable version "3.5.3", 
required is "3.3") 
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython3.5m.so (found suitable 
exact version "3.5") 
-- will install python files in /usr/lib/python3/dist-packages
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_INSTALL_LOCALSTATEDIR
    CMAKE_INSTALL_SYSCONFDIR
    CPACK_DEBIAN_PACKAGE_DEPENDS


-- Build files have been written to: /morse-simulator-1.4/obj-x86_64-linux-gnu
make[1]: Leaving directory '/morse-simulator-1.4'
   dh_auto_build
dh_auto_build: Compatibility levels before 9 are deprecated (level 8 in use)
        make -j1
make[1]: Entering directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
/usr/bin/cmake -H/morse-simulator-1.4 
-B/morse-simulator-1.4/obj-x86_64-linux-gnu --check-build-system 
CMakeFiles/Makefile.cmake 0
/usr/bin/cmake -E cmake_progress_start 
/morse-simulator-1.4/obj-x86_64-linux-gnu/CMakeFiles 
/morse-simulator-1.4/obj-x86_64-linux-gnu/CMakeFiles/progress.marks
make -f CMakeFiles/Makefile2 all
make[2]: Entering directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
make -f CMakeFiles/man.dir/build.make CMakeFiles/man.dir/depend
make[3]: Entering directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
cd /morse-simulator-1.4/obj-x86_64-linux-gnu && /usr/bin/cmake -E cmake_depends 
"Unix Makefiles" /morse-simulator-1.4 /morse-simulator-1.4 
/morse-simulator-1.4/obj-x86_64-linux-gnu 
/morse-simulator-1.4/obj-x86_64-linux-gnu 
/morse-simulator-1.4/obj-x86_64-linux-gnu/CMakeFiles/man.dir/DependInfo.cmake 
--color=
Scanning dependencies of target man
make[3]: Leaving directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
make -f CMakeFiles/man.dir/build.make CMakeFiles/man.dir/build
make[3]: Entering directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
env 
PYTHONPATH=/morse-simulator-1.4/obj-x86_64-linux-gnu:/morse-simulator-1.4/obj-x86_64-linux-gnu/src:/morse-simulator-1.4/obj-x86_64-linux-gnu/fakeenv:/morse-simulator-1.4/src:/morse-simulator-1.4/testing:/morse-simulator-1.4/bindings/pymorse/src/:$PYTHONPATH
 PYTHONDONTWRITEBYTECODE="morse" MORSESOURCE=/morse-simulator-1.4 
/usr/bin/python3 /usr/bin/sphinx-build -b man -c 
/morse-simulator-1.4/obj-x86_64-linux-gnu/doc /morse-simulator-1.4/doc/man 
/morse-simulator-1.4/obj-x86_64-linux-gnu/doc/man && /bin/gzip -f 
/morse-simulator-1.4/obj-x86_64-linux-gnu/doc/man/*.1
Running Sphinx v1.5.6
making output directory...

Exception occurred:
  File "conf.py", line 15, in <module>
ImportError: No module named 'version'
The full traceback has been saved in /tmp/sphinx-err-lq8tqd1q.log, if you want 
to report the issue to the developers.
Please also report this if it was a user error, so that a better error message 
can be provided next time.
A bug report can be filed in the tracker at 
<https://github.com/sphinx-doc/sphinx/issues>. Thanks!
CMakeFiles/man.dir/build.make:60: recipe for target 'CMakeFiles/man' failed
make[3]: *** [CMakeFiles/man] Error 1
make[3]: Leaving directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
CMakeFiles/Makefile2:134: recipe for target 'CMakeFiles/man.dir/all' failed
make[2]: *** [CMakeFiles/man.dir/all] Error 2
make[2]: Leaving directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
Makefile:141: recipe for target 'all' failed
make[1]: *** [all] Error 2
make[1]: Leaving directory '/morse-simulator-1.4/obj-x86_64-linux-gnu'
dh_auto_build: make -j1 returned exit code 2
debian/rules:8: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2

Attachment: signature.asc
Description: PGP signature


--- End Message ---
--- Begin Message ---
Source: morse-simulator
Source-Version: 1.4-3

We believe that the bug you reported is fixed in the latest version of
morse-simulator, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 853...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sylvestre Ledru <sylves...@debian.org> (supplier of updated morse-simulator 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sun, 15 Apr 2018 18:40:27 +0200
Source: morse-simulator
Binary: morse-simulator morse-simulator-data morse-simulator-doc 
python3-morse-simulator
Architecture: source
Version: 1.4-3
Distribution: unstable
Urgency: medium
Maintainer: Debian Science Team 
<debian-science-maintain...@lists.alioth.debian.org>
Changed-By: Sylvestre Ledru <sylves...@debian.org>
Description:
 morse-simulator - Multi-OpenRobot Simulation Engine
 morse-simulator-data - Multi-OpenRobot Simulation Engine
 morse-simulator-doc - Multi-OpenRobot Simulation Engine - Documentation
 python3-morse-simulator - Multi-OpenRobot Simulation Engine
Closes: 853557 861028
Changes:
 morse-simulator (1.4-3) unstable; urgency=medium
 .
   * Fix the FTBFS by adding the version.py file from usptream
     (Closes: #853557)
   * Package moved on salsa
   * Standards-Version updated to 4.1.3
   * Move to compat mode 8
   * Fix priority-extra-is-replaced-by-priority-optional
   * Explicit python3-setuptools as dep
   * Rename morse => morsesim to avoid a conflict
     For now, it still contains a symlink from morse to morseim
     I will remove it later.
     (Closes: #861028)
   * Disable the sphinx ext vimeo & gallery until
     https://github.com/morse-simulator/morse/issues/792 is fixed
 .
   [ Séverin Lemaignan ]
   * Relax the need for Sphinx 1.3 as the original issue (#792711) has been
     fixed upstream
Checksums-Sha1:
 dc2badbb3940f0286b6f38128f0a270ca8db3437 2358 morse-simulator_1.4-3.dsc
 81cf062b768ddff19b21865736123cc83269b7d1 6576 
morse-simulator_1.4-3.debian.tar.xz
 225c1f742c848b88801e46a1f31d21a026b42b8f 9319 
morse-simulator_1.4-3_amd64.buildinfo
Checksums-Sha256:
 d450ba8264355d86a20aaf753a84d67c196e0cd18e54d1c344430eb099b3027e 2358 
morse-simulator_1.4-3.dsc
 e7b725fe9c7c74e7ab152afaea28ea7510e931b28a1ad532d9dfe54477295073 6576 
morse-simulator_1.4-3.debian.tar.xz
 bafc33a39359ade0368a3b867e82bb3a2b387b8c8edf3ce39e696c2eb6282f9b 9319 
morse-simulator_1.4-3_amd64.buildinfo
Files:
 5ce6f6dd8adf78f740c7ac743569ac50 2358 science optional 
morse-simulator_1.4-3.dsc
 9706c779f08e254c7cb1672cb3e0ebcc 6576 science optional 
morse-simulator_1.4-3.debian.tar.xz
 2a8248aea57bcacdeeb2d6e573783c51 9319 science optional 
morse-simulator_1.4-3_amd64.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEtg21mU05vsTRqVzPfmUo2nUvG+EFAlrTj7cACgkQfmUo2nUv
G+F/xw/9GAYAhdM+2csEWA5sXLzkdccwPqvS2w1W27Z2hAWJBhF7c5NPUjQF7EsK
cTPzsH5DbaEgSwt0H06w/P0BvJFAkr08AJjxuhegcUcGGZheB7ngiJKrsGBG8BhM
7WHnLusbsZgxYsLcuTYsX07jrK5cXhSfv8gYq05nBc230b87Zo7VnhDOLSEf7Llx
1j4OtuFFSqDGgHVAJN9YicioTPPILbF0EzcfYGbYTulJPblAkAcWNNdTuqYwgll4
j5O2HOdoq7fytTtuSwJwcKWIPBCBfhPdKWfk9mmA8U4hLfd1Za/72r5J8Lk/KizM
rfgMNL7XHzKw0vodlke+DUlbsWSFLUfNtJBucaxf7dBGSCWw3kvuvbXpo51er/ns
JUE2TJYqLyIi6Gv1m3XqvqVviq+Kmwyt0n8UuARuB43ekalHBu5FI9ZKsE2CI3I/
ex9KZYBQ6QW1pgpFXNsew+th7kvABcadIt6XCZ9wNC/IaLvxfuFxzQQ205q6HLg1
Vw/I+Jf7+2pF3dQE7RSHe8idWVwa59esFtbHFDAKD9/CwI2UPy48mGWim5ymruEE
yTPxP05dVfAZuuxta1ZtXSd78n2N/4AU+llMU5MbvoexNgii7VQf0PKWlLfz/RdN
CiQSl9erx2DbM9juq6yNYpXwb189rRUHxvqCbFYlQEEWiVViLMU=
=HsKU
-----END PGP SIGNATURE-----

--- End Message ---
-- 
debian-science-maintainers mailing list
debian-science-maintainers@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/debian-science-maintainers

Reply via email to