Package: spyder
Version: 4.0.0~rc3+dfsg1-1
Severity: normal

spyder 4 (currently on salsa in experimental branch) needs python
modules python-language-server and qdarkstyle

These are currently not packaged for Debian, so this is a
Request For Help to get them packaged so we can proceed with the
spyder upgrade.

-- System Information:
Debian Release: bullseye/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 5.3.0-2-amd64 (SMP w/4 CPU cores)
Kernel taint flags: TAINT_OOT_MODULE, TAINT_UNSIGNED_MODULE
Locale: LANG=en_AU.UTF-8, LC_CTYPE=en_AU.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_AU:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages spyder depends on:
ii  python3-spyder  4.0.0~rc3+dfsg1-1
ii  python3.7       3.7.5-2

spyder recommends no packages.

spyder suggests no packages.

Versions of packages python3-spyder depends on:
ii  libjs-jquery              3.3.1~dfsg-3
ii  libjs-mathjax             2.7.4+dfsg-1
ii  pylint                    2.4.4-1
ii  python3                   3.7.5-3
ii  python3-atomicwrites      1.1.5-2
ii  python3-chardet           3.0.4-4
ii  python3-cloudpickle       1.2.1-2
ii  python3-diff-match-patch  20181111-2
ii  python3-intervaltree      3.0.2-1
ii  python3-jedi              0.14.1-1
ii  python3-keyring           18.0.1-1
ii  python3-nbconvert         5.6.0-2
ii  python3-numpydoc          0.7.0-1
ii  python3-pexpect           4.6.0-1
ii  python3-pickleshare       0.7.5-1
ii  python3-psutil            5.6.7-1
ii  python3-pygments          2.3.1+dfsg-1
ii  python3-pympler           0.7+dfsg1-1
ii  python3-qtawesome         0.4.4+ds1-3
ii  python3-qtconsole         4.3.1-1
ii  python3-qtpy              1.3.1-3
ii  python3-sphinx            1.8.5-3
ii  python3-spyder-kernels    1.8.0-1
ii  python3-watchdog          0.9.0-3
ii  python3-zmq               17.1.2-3
ii  spyder-common             4.0.0~rc3+dfsg1-1

Versions of packages python3-spyder suggests:
ii  cython3             0.29.14-0.1+b1
ii  python3-matplotlib  3.0.2-2+b2
ii  python3-numpy       1:1.17.4-3
ii  python3-pandas      0.25.3+dfsg-4
ii  python3-pil         6.2.1-2+b1
ii  python3-scipy       1.3.3-1
ii  python3-sympy       1.4-1

Versions of packages python3-pyqt5 depends on:
ii  libc6                             2.29-3
ii  libgcc1                           1:9.2.1-21
ii  libpython3.7                      3.7.5-2
ii  libqt5core5a [qtbase-abi-5-12-5]  5.12.5+dfsg-2
ii  libqt5dbus5                       5.12.5+dfsg-2
ii  libqt5designer5                   5.12.5-2
ii  libqt5gui5                        5.12.5+dfsg-2
ii  libqt5help5                       5.12.5-2
ii  libqt5network5                    5.12.5+dfsg-2
ii  libqt5printsupport5               5.12.5+dfsg-2
ii  libqt5test5                       5.12.5+dfsg-2
ii  libqt5widgets5                    5.12.5+dfsg-2
ii  libqt5xml5                        5.12.5+dfsg-2
ii  libstdc++6                        9.2.1-21
ii  python3                           3.7.5-3
ii  python3-sip [sip-py3api-12.7]     4.19.19+dfsg-2+b1

Versions of packages python3-pyqt5 suggests:
ii  python3-pyqt5-dbg  5.12.3+dfsg-3+b1

-- no debconf information

-- 
debian-science-maintainers mailing list
debian-science-maintainers@alioth-lists.debian.net
https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/debian-science-maintainers

Reply via email to