Source: yade
Severity: normal
Control: block 840501 by -1

Hi,

we are planning to transition ipython from version 2.4 to 5 [1].

I tried building yade against ipython 5.1.0-1 (from experimental), but
it failed. A file with the error message is attached.

Please help to fix this to speed up the transition.

Thanks,
Tobias

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=840501
dh_numpy
#Generate docs
cd /home/thansen/src/ipython/yade/yade-2016.06a/doc/sphinx; PYTHONPATH=. 
/home/thansen/src/ipython/yade/yade-2016.06a/debian/tmp/usr/bin/yade 
yadeSphinx.py; cd _build/latex; xelatex Yade.tex; xelatex Yade.tex; xelatex 
Yade.tex;
TCP python prompt on localhost:9000, auth cookie `kaysec'
Welcome to Yade 2016.06a 
Warning: no X rendering available (see 
https://bbs.archlinux.org/viewtopic.php?id=13189)
XMLRPC info provider on http://localhost:21000
Running script yadeSphinx.py
warning: unable to convert `\araa'
warning: unable to convert `\aj'
warning: reference `dec' undefined
warning: unable to convert `\aap'
warning: reference `aug' undefined
Running Sphinx v1.4.8

Exception occurred:
  File 
"/home/thansen/src/ipython/yade/yade-2016.06a/doc/sphinx/ipython_directive200.py",
 line 149, in <module>
    from IPython import Config, InteractiveShell
ImportError: cannot import name Config
The full traceback has been saved in /tmp/sphinx-err-WCdgBk.log, if you want to 
report the issue to the developers.
Please also report this if it was a user error, so that a better error message 
can be provided next time.
A bug report can be filed in the tracker at 
<https://github.com/sphinx-doc/sphinx/issues>. Thanks!
Traceback (most recent call last):
  File "/home/thansen/src/ipython/yade/yade-2016.06a/debian/tmp/usr/bin/yade", 
line 182, in runScript
    execfile(script,globals())
  File "yadeSphinx.py", line 224, in <module>
    makeBaseClassesClickable((outDir+'/html/yade.wrapper.html'),writer)
  File "yadeSphinx.py", line 154, in makeBaseClassesClickable
    for l in open(f):
IOError: [Errno 2] No such file or directory: '_build/html/yade.wrapper.html'
/usr/lib/python2.7/dist-packages/IPython/config.py:13: ShimWarning: The 
`IPython.config` package has been deprecated. You should import from 
traitlets.config instead.
  "You should import from traitlets.config instead.", ShimWarning)
/usr/lib/python2.7/dist-packages/IPython/core/interactiveshell.py:448: 
UserWarning: As of IPython 5.0 `PromptManager` config will have no effect and 
has been replaced by TerminalInteractiveShell.prompts_class
  warn('As of IPython 5.0 `PromptManager` config will have no effect'
-- 
debian-science-maintainers mailing list
debian-science-maintainers@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/debian-science-maintainers

Reply via email to