----- Mail original -----
> De: "Andreas Tille" <andr...@fam-tille.de>
> À: 777...@bugs.debian.org
> Cc: debian-pyt...@lists.debian.org, "Debian Science List" 
> <debian-science@lists.debian.org>
> Envoyé: Vendredi 2 Février 2018 09:16:55
> Objet: Preconditions for python-moto finished - help needed to build package 
> itself
> 
> Hi,
> 
> as you might have noticed I finalised the preconditions to build
> python-moto which is in salsa.d.o[1].  When trying to build I get:
> 
> 
> 
>    dh_auto_test -O--buildsystem=pybuild
> I: pybuild base:184: python2.7 setup.py test
> running test
> running egg_info
> writing requirements to moto.egg-info/requires.txt
> writing moto.egg-info/PKG-INFO
> writing top-level names to moto.egg-info/top_level.txt
> writing dependency_links to moto.egg-info/dependency_links.txt
> writing entry points to moto.egg-info/entry_points.txt
> reading manifest file 'moto.egg-info/SOURCES.txt'
> reading manifest template 'MANIFEST.in'
> writing manifest file 'moto.egg-info/SOURCES.txt'
> running build_ext
> Traceback (most recent call last):
>   File "setup.py", line 68, in <module>
>     "Topic :: Software Development :: Testing",
>   File "/usr/lib/python2.7/dist-packages/setuptools/__init__.py", line 129,
>   in setup
>     return distutils.core.setup(**attrs)
>   File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
>     dist.run_commands()
>   File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
>     self.run_command(cmd)
>   File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
>     cmd_obj.run()
>   File "/usr/lib/python2.7/dist-packages/setuptools/command/test.py", line
>   226, in run
>     self.run_tests()
>   File "/usr/lib/python2.7/dist-packages/setuptools/command/test.py", line
>   248, in run_tests
>     exit=False,
>   File "/usr/lib/python2.7/unittest/main.py", line 94, in __init__
>     self.parseArgs(argv)
>   File "/usr/lib/python2.7/unittest/main.py", line 149, in parseArgs
>     self.createTests()
>   File "/usr/lib/python2.7/unittest/main.py", line 158, in createTests
>     self.module)
>   File "/usr/lib/python2.7/unittest/loader.py", line 130, in
>   loadTestsFromNames
>     suites = [self.loadTestsFromName(name, module) for name in names]
>   File "/usr/lib/python2.7/unittest/loader.py", line 103, in
>   loadTestsFromName
>     return self.loadTestsFromModule(obj)
>   File "/usr/lib/python2.7/dist-packages/setuptools/command/test.py", line
>   52, in loadTestsFromModule
>     tests.append(self.loadTestsFromName(submodule))
>   File "/usr/lib/python2.7/unittest/loader.py", line 100, in
>   loadTestsFromName
>     parent, obj = obj, getattr(obj, part)
> AttributeError: 'module' object has no attribute 'backport_assert_raises'

backport_assert_raises is a python file in tests directory of moto, maybe it is 
missing in your install?

> E: pybuild pybuild:283: test: plugin distutils failed with: exit code=1:
> python2.7 setup.py test
> dh_auto_test: pybuild --test -i python{version} -p 2.7 returned exit code 13
> debian/rules:6: recipe for target 'build' failed
> make: *** [build] Error 25
> dpkg-buildpackage: error: debian/rules build gave error exit status 2
> 
> 
> 
> I was seeking for some missing backport module but I have no real clue
> what might be missing.  Any help would be welcome.
> 
> Kind regards
> 
>      Andreas.
> 
> 
> 
> [1]
> 
> --
> http://fam-tille.de
> 
> 

Reply via email to