On 1/7/19 21:14, John Paul Adrian Glaubitz wrote:

On Jan 7, 2019, at 9:07 PM, Frank Scheiner <frank.schei...@web.de> wrote:

On 1/7/19 16:35, John Paul Adrian Glaubitz wrote:
On 1/7/19 4:31 PM, John Paul Adrian Glaubitz wrote:
I tried to install GRUB using a ELF boot image:

root@debian:~/grub2# grub-install /dev/vdiska
Installing for sparc64-ieee1275 platform.
grub-install: error: the size of `/boot/grub/sparc64-ieee1275/boot.img' is not 
root@debian:~/grub2# ls -l /boot/grub/sparc64-ieee1275/boot.img
-rw-r--r-- 1 root root 816 Jan  7 18:29 /boot/grub/sparc64-ieee1275/boot.img

So, the generated ELF image is too big. No idea yet how to address this.
It does seem to work, however. At least with GPT:
                          GNU GRUB  version 2.02+dfsg1-9
  |*Debian GNU/Linux                                                           |

Did you maybe already install the v1 version on this GPT disk?

No, I didn’t. I only ever tried v2 on this machine. In fact, I built v2 first, 
then ran the tests.

As both v1 and v2 use the same version number it's not clear if this is one or 
the other.

Yes, but I know what I did. I‘m not sure why you are questioning that. Do you 
see any unexpected results?

No, but from the `grub-install` output I didn't expect that the installation worked and after comparing the versions of v1 and v2, I just wanted to be sure about the details. I was not questioning what you did. :-)


Reply via email to