Hi Mike,

I ran into exactly the same issue on my Sun Ultra 60 with partman getting stuck at 33% when starting (before even accessing the partioning menu).

I found that the issue was related to the RAID detection, although I had no RAID and the only disk installed has been zeroed with dd.

Here is what I did :
- boot the installer in expert mode, where every step will be accessible in the installer menu, - after the stage "load installation components" and before "disk partitionning", - I opened a shell where I moved into /tmp the kernel module md.so and the command mdadm (localized with find), - check that no process mdadm was running and no module md/mdraid was loaded,
- close the shell,
- carry on with the partitionning,
- there partman gets grumpy with a big red screen saying it cannot use the raid software, but not angry as it carries on straight to the disk partitioning.

Hope it helps.

I tried to find an option to tell the installer not to use RAID with no success (mdadm=false nor mdraid=false did not work).
If somebody knows a better/simpler way ...

Best regards,

Reply via email to