(Since I didn't hit reply all on the previous one, whoops I'm not so good at 
mailing lists)

Thanks for the advice. The 5.16 CD is stable enough to pass the installation 
(aside from a video text bug), however in rebooting it blows up. I was able to 
console install it using the same trick as with the U10 (setting the output and 
input devices to TTYA). I'm going to post what I did here so anyone else with 
an UltraSPARC III/T1 based machine can get "something" going. 

I initially tried the 4.19 CD however after grabbing the new gpg key and doing 
an upgrade once the OS was installed it blew up a few minutes in. Namely the 
upgrade failed really early on and I was unable to sudo, and if I logged out I 
was unable to login as well. It didn't even try to let me enter in a password, 
it simply told me that it was incorrect.

So what I did was I used the 5.16 CD, then when I was asked the tasksel 
question I used Ctrl-A and 2 to move to the shell, chrooted /target, and used 
busybox wget on the kernel you linked and installed it. This gave me a working 
system with the 4.19 kernel. For some reason or another though networking did 
not want to work on 4.19, so I mounted the CD, and installed the deb and udebs 
from there (and the kernel image from 
 and networking finally worked. I'd install that too or the other udebs for the 
one you linked instead of just using the kernel. 

Now it's rock solid and I can do my weird SPARC experiments. Thanks so much. 
> On 10/13/2022 4:14 AM EDT Frank Scheiner <frank.schei...@web.de> wrote:
> Hi Jake,
> On 13.10.22 07:13, j...@pawlicker.com j...@pawlicker.com wrote:
> > I've also been able to confirm that this happens with Kernel 5.16 or at
> > least similar bugs do such as Unable to handle kernel NULL pointer
> > dereference, programs such as postgresql break dramatically, and another
> > time SSH panicked the system with a kernel unaligned access. This
> > happened during apt-get:
> > [...]
> Try with kernel 5.9.x, or maybe better already use 4.19.x on UltraSPARC
> IIIi which works OK most of the time AFAIR. You can get those from
> snapshot.debian.org (e.g. [1] or [2]).
> [1]:
> http://snapshot.debian.org/archive/debian-ports/20190719T183113Z/pool-sparc64/main/l/linux/linux-image-4.19.0-5-sparc64_4.19.37-6_sparc64.deb
> [2]:
> http://snapshot.debian.org/archive/debian-ports/20190719T183113Z/pool-sparc64/main/l/linux/linux-image-4.19.0-5-sparc64-smp_4.19.37-6_sparc64.deb
> ...but unsure if your system will run stable enough to successfully
> finish the installation. Alternatively try to reinstall with an older
> ISO and work from there:
> * with 5.9.0-4:
> https://cdimage.debian.org/cdimage/ports/snapshots/2020-12-03/debian-10.0.0-sparc64-NETINST-1.iso
> * with 4.19.0-5:
> https://cdimage.debian.org/cdimage/ports/snapshots/2019-06-26/debian-10.0-sparc64-NETINST-1.iso
> ****
> There seems to be a problem with UltraSPARC T1s and I strongly believe
> this or another problem also affects UltraSPARC III(i)s. I have tested a
> variety of processors here:
> https://lists.debian.org/debian-sparc/2021/12/msg00004.html
> For more details on this/these issue(s) see:
> https://lists.debian.org/debian-sparc/2021/03/msg00045.html
> ...and:
> https://lists.debian.org/debian-sparc/2022/02/msg00000.html
> Cheers,
> Frank

Reply via email to