Narcis Garcia:

> Hola, estic intentant fer un paquet que depengui d'un altre
> (iputils-ping), però la versió d'aquest altre a Debian està
> marcada amb una notació que no domino:
> 3:20161105-1
> 
> - Quina és la versió del programari? 3?

La versió del codi original és 20161105, la de debian 1, però
degut a diversos canvis en la manera de versionar els orginals
(fins a 3 cops), ha calgut afegir el prefix 3 per poder fer les
comparacions.

https://www.debian.org/doc/debian-policy/ch-controlfields.html#s-f-Version

> - Quina és la millor fórmula pel fitxer «control» del meu nou paquet
> tenint en compte que em serveix qualsevol des de la 3:20020927 de
> Debian-Sarge o més enrere si fos el cas?
> 
> Depends: iputils-ping (>= 3)
> Depends: iputils-ping (>= 20020927)

Aquestes segur que no perquè s'interpreta que en realitat duen
el prefix «0:» al davant i no t'interessa en cap dels dos casos.

> Depends: iputils-ping (>= 3:20020927)

Aquesta sembla una bona aposta. En qualsevol cas, et recomano que
facis proves amb el dpkg, per exemple:

$ dpkg --compare-versions 3:20161105-1 ge 3:20020927 && echo true
true

Salut,
Alex

Respondre per correu electrònic a