El 01/12/16 a las 17:31, Rivera Valdez escribió:
No hombre, no está bloqueado, solo es un cambio de "nombre".
¿Hay alguna manera de volver a poner el "nombre" anterior?


El comando "ifconfig" te dio "eth0" (que es la tarjeta de red)


Entiendo que el sistema instalado no encuentre la placa por tener el
"nombre" cambiado, pero ¿por qué no la encuentran los sistemas que
booteo en LiveUSB?
¿Puede ser que el firmware (non-free) de la placa wireless que instalé
y luego desinstalé (firmware-iwlwifi) haya modificado el firmware de
la placa de red?
En ese caso, ¿dónde/cómo se edita eso?


Creo que te estás liando, el firmware es para el wifi, no para el cable


Y he de suponer que ni en Trisquel ni en Parabola tendrías wifi porque son
proyectos de software libre y el firmware que vas a instalar (o has
instalado) no lo es.
Correcto. Pero los derivados de Debian (Trisquel) no se conectan a la
red cableada. Parabola/Arch en cambio usan la red cableada con este
"nombre" nuevo (enp6s0). ¿Se le puede indicar al sistema que use ese
otro "nombre" entonces?


Que Parabola o Arch usen ese nombre a tí te tiene que dar igual, usa los datos que te ofrece tu Debian, el que tienes INSTALADO.



El problema es no sabemos que has hecho para que no tengas conexión por
cable, o sea, como intestaste activar el wifi.
Instalé el paquete firmware-iwlwifi con gdebi (los mismos pasos que
reproduje en la salida de terminal que pegué antes), descargué y volví
a cargar el módulo indicado (modprobe -r iwlwifi ; modprobe iwlwifi),
y como la conexión wireless seguía sin aparecer, desinstalé iwlwifi
con apt-get.
Al reiniciar el sistema ya no se conectaba con la placa de red (que es
esta, según lshw):

Ethernet interface
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controler
Realtek Semiconductor Co., Ltd.

Así que deshaz todo lo que hayas hecho hasta que tenías conexión por cable y
después sigue los pasos para instalar el firmware como te pone en la wiki
[1].
Hecho. Pero deshechos todos los pasos, no vuelve a conectarse por
cable (eth0) ni de ningún otro modo.

Si no te acuerdas reinstala el sistema. No te compliques.
Preferiría evitar esto. El disco está encriptado y desde las distros
en modo Live no consiguen abrir el contenido, de modo que hacer un
backup está doblemente complicado (al margen de que reinstalar el
sistema me significaría una enorme pérdida de tiempo adicional, desde
ya).

Si lo ves muy complicado usa una imagen live con el firmware non-free
incluido [2].
Gracias por el link. Si eventualmente tengo que reinstalar todo el
sistema quizá me sirva, pero en rigor todo lo que necesito es que el
sistema se conecte por cable de red como lo venía haciendo antes.


Es que tienes que deshacer todo lo que has hecho hasta este punto, hasta que tenías conexión de red.



Si hay alguna documentación técnica que leer donde se explique cómo
hacer esto a mano (por más que sea largo) agradecería que me la
indiquen.

Y gracias de nuevo por la ayuda, desde ya. Esto me está impidiendo
seguir trabajando y reinstalar todo el sistema sería la peor solución
(al menos en principio)...


Probaste desde consola configurar la placa de red con el nombre nuevo?:

ifconfig enp6s0 up
ifconfig enp6s0 192.168.1.10 netmask 255.255.255.0
route add default gateway 192.168.1.1

Obviamente cambiando las ips (y mascara de red) a las que correspondan
de tu maquina y del gateway.

Si eso te funciona, modifica el nombre en /etc/network/interfaces

Saludos,

Javier.


Se supone que tu tarjeta de red es "eth0", pero al usar un live de Arch éste lo nombra como "enp6s0"... ¿y que más dá? como si se llama pepito grillo!!!

Usa los datos que te proporciona el sistema que tienes instalado, el que no te funciona, el que quieres arreglar.

Si en un principio tenia conexión por red pero al intentar activar el wifi lo perdiste todo eso quiere decir:

a) Que la tarjeta de red funciona (o funcionaba)
b) Que has hecho algo mal (pero lo vas a arreglar, confío en tí)

Así que deja el pc en ese punto, en donde todo (o casi todo) funcionaba bien.

Y cuando lo tengas todo como antes le metes mano al wifi instalando el firmware como te pone en la wiki (porque se supone que ya tendrás internet), o sea, añadiendo el non-free al repositorio e instalando el paquete firmware-iwlwifi.

A ver si me das una alegría la próxima vez que escribas :-)

Saludos


Responder a