Anthony Campbell <> wrote on Tue, Feb 02, 2010 at 
08:35:29AM +0000:
> On 01 Feb 2010, Joey Morris wrote:
> > Anthony Campbell <> wrote on Mon, Feb 01, 2010 at 
> > 09:13:41AM +0000:
> > > On 31 Jan 2010, Joey Morris wrote:
> > > > I start my X session with startx, and lately I've noticed that some
> > > > (but not all) of my .Xmodmap settings are being lost once my X session
> > > > is up. I think this behavior started sometime in the past month or two.
> > > > 
> > > [snip] 
> > > 
> > > I also use startx, with Icewm. I encountered problems with ~/.Xmodmap
> > > some time ago. I solved it by trying out various /usr/bin/xmodmap
> > > commands on the command line and when I got them working I put them in
> > > .xinitrc. I no longer use ~/.Xmodmap.
> > 
> > Thanks. I tried removing the line that loads .Xmodmap from my .xinitrc
> > and replacing it with direct calls to xmodmap -e, but that didn't
> > help. Just like my method of loading .Xmodmap, the modifier map is
> > correct immediately after the calls to xmodmap -e, but once the window
> > manager is up and I have an xterm, the modifier map is wrong. It looks
> > like the keysym command survives, but something moves that second
> > Control_L back to the Lock modifer.
> > 
> Did you try running the xmodmap -e e stuff at the command line in an
> xterm? That might give you a clearer idea of what is wrong.

Yes, I've done that. In fact, since this problem started, the first
thing I do after restarting X is to run the following in an xterm to
get the modifiers set up the way I want them:

$ xmodmap -e "clear Lock"
$ xmodmap -e "add Control = Control_L"

I get no errors or warnings, and everything works fine afterwards. I
skip the "keysym Caps_Lock = Control_L" step because it isn't
necessary (it's the one part of my .Xmodmap that sticks around), but I
did verify that it worked during my original troubleshooting.

To UNSUBSCRIBE, email to 
with a subject of "unsubscribe". Trouble? Contact

Reply via email to