On Fri, 16 Sep 2016 13:44:09 -0400 (EDT)
Alan McConnell <a...@his.com> wrote:

> For some reason, my sound doesn't work on my new machine with its
> present jessie install.  It worked on my old machine(which had
> jessie) and it works fine here on Windoze(I use youtube to play old
> Bernie Sanders' speeches, or Mozart<g>).  So what do I have to do?  I
> can't find alsa to install, and pulsesudio is already installed.
> Any and all suggestions/fixes appreciated.  Please spare the
> imprecations and chastisements!

Could I first suggest that you get hold of a recent version of
Knoppix? Not just to solve this problem, but you seem to be at a point
where you need a variety of help. It takes forever to boot up, but it's
worth waiting for.

It is based on Debian, and its particular selling point is its hardware
driving abilities. It is based on unstable rather than a released
Debian, but it is still usually possible to see how it achieves
something and to transfer the knowledge to a standard Debian. I won't
say that I've never seen hardware that beats it, but it doesn't happen

More specifically, sound has always been a problem with Linux, not
least because of the variety of systems involved, some of them
optional, and the helpful instructions on the Net which cover many
years and are mostly obsolete. I've no idea of the current state of the
art, as I actually haven't had a sound problem for at least a year, so
someone will correct any of my recollections which are incorrect. I
also don't have a jessie system, but sound changes relatively slowly,
and my wheezy and sid installations look fairly similar.

Basically, there is a low-level driver for the hardware you have, and
various layers of software on top of that. Probably the first job is to
check that you are getting the hardware driver(s) installed, and the
sound card(s) is/are available.

I'm fairly sure pulseaudio is not yet standalone, it operates through
alsa, and there are other tools to operate alsa directly. Rather than
try unfamiliar software to check for cards, look in /proc/asound/cards
(cat /proc/asound/cards). If you don't see the sound device you expect
to see, you're probably not getting the driver installed. If you see
more than one device, and the one you expect isn't the first in the
list, I've reached the limit of my knowledge. I've solved that one
before, but alsa configuration has changed since then, and systemd
has arrived, and you need up-to-date instructions.

If you see the expected device first in the list, then probably all is
well with drivers. Check the audio mixer settings. Cards have different
numbers of level adjustments, you may need more than one turned up to
get internal sound.

If you have a speaker icon on your desktop, right-click and run the
audio mixer. If you don't, try alsamixer from the command line. If it
can't find that, install the package alsamixergui and try again. When
you can see that the right sliders are turned up (all of them if
necessary) try speaker-test -c 2 from the command line, which should
give you noise tests on the two main channels. If you get to that
point, everything ought to work. If not, come back and we'll try to get


Reply via email to