On Tue, 20 Feb 2018, Reco wrote:
On Tue, Feb 20, 2018 at 12:23:06PM +0100, Roger Price wrote:
Later the installation hangs with the message:

 in-target: Failed to fetch
 Cannot initiate the connection to debian.mirrors.ovh.net:80
 (2001:41d0:202:100:213:32:5:7). - connect (101: Network is unreachable)
 [IP 2001:41d0:202:100:213:32:5:7 80]

There is no mention of IPv4 and I do not have IPv6.

Of course you have IPv6, probably in the form of SLAAC/RA. How else
Linux kernel used in the installer would know which IPv6 address to use
and which IPv6 route to choose to 2001:41d0:202:100:213:32:5:7.

I have a TP-Link TL-WR1043ND v3 router sold as IPv6 capable. I selected SLAAC and the following was reported in the system log:

 Feb 19 23:41:47  IPv6 NOTICE  getSlaacParameters 477 sscanf address and prefix 
 Feb 19 23:43:32  IPv6 INFO    IPv6 is not enabled.

IPv6 management in the router has hung and I cannot select an alternative to SLAAC.

On the EeePC Ctl-Alt-F3 /dev/tty3:
 ~ # ip address
   inet scope global enp0s4
   inet6 fe80::22cf:30ff:fe10:43fd/64 scope link

The "fe" at the beginning of the IPv6 address says that this is not capable of working with the public IPv6 network.

On Tue, 20 Feb 2018, Brian wrote:
On Tue 20 Feb 2018 at 13:39:25 +0000, Curt wrote:
On 2018-02-20, Reco <recovery...@gmail.com> wrote:


So I guess the 'netcfg/disable_autoconfig=true' as boot parameter would
allow for manual configuration of the network within the installer, thus
obviating the IPv6 conundrum.

I do not understand the netcfg/disable... notation. It is not described in the debconf man page, neither in Joey Hess' tutorial at http://www.fifi.org/doc/debconf-doc/tutorial.html . In any case, the graphical installer asks the question.

Yet what installer *does* have that's /proc.
So, wait for the network autoconfiguration, switch to root vt, invoke:

echo 1 > /proc/sys/net/ipv6/conf/all/disable_ipv6

This fixed my problem. I tried again to install, and set disable_ipv6 to 1 before starting the step "Install the base system". The installation of stretch/Xfce i386 was successful! After booting, I set GRUB_CMDLINE_LINUX="ipv6.disable=1 net.ifnames=0" in /etc/default/grub and ran update-grub. (Maybe the net.ifnames=0 is not essential.) I also installed rt2860.bin needed for the WiFi. I recovered the /home partition from an earlier installation of openSUSE 12.2, re-booted and I now have my EeePC running with stretch. Thanks to all who commented in this thread.

I will not mark the subject [SOLVED] since the underlying problem of why wget fails with 12 mirrors out of 13 is not solved.


Reply via email to