On February 12, 2018 6:10:18 AM EST, Julien Cristau <jul...@cristau.org> wrote:
>On 12/03/2017 07:38 PM, Afif Elghraoui wrote:
>> 
>> 
>> على السبت  2 كانون الأول 2017 ‫06:14، كتب Julien Cristau:
>>> On Wed, Oct 18, 2017 at 00:40:12 -0400, Afif Elghraoui wrote:
>>>
>>>>
>>>>
>~~~https://anonscm.debian.org/cgit/debian-med/sga.git/tree/debian/control
>>>> Priority: optional
>>>> Build-Depends: debhelper (>= 10),
>>>>                dh-autoreconf,
>>>>                libsparsehash-dev,
>>>>                zlib1g-dev | libz-dev,
>>>>                libbamtools-dev,
>>>>                gawk,
>>>>                help2man,
>>>> # Run-Time Depends
>>>> # (to prevent building on architectures where it won't be
>installable)
>>>>           samtools,
>>>>           python,
>>>>           python-ruffus,
>>>>                python-pysam
>>>> Standards-Version: 4.1.0
>>>> ~~~
>>>>
>>>> ...which is an abuse of the build-depends field since those at the
>>>> bottom are not actually needed for building the package.
>>>>
>>> I think this is actually a reasonable use of build-depends.
>> 
>> How? They are packages not needed during the build process. Do you
>think
>> this needs a special build profile?
>> 
>No, I don't?

I'm trying to understand how you think that's a reasonable use of 
build-depends, because I can't see how it's not an abuse.

>  What problem are you actually trying to solve?
>

Besides unnecessary repetition in d/control, lying to the build server in 
telling it that it needs a package in order to build could cause unnecesssary 
problems in bootstrapping.

Afif

Reply via email to