I don't see this at all using 5.8.5 on Linux.

        > cat db.pl
        use Config qw(myconfig);
        print Config->myconfig;

        > perl db.pl > ordinary.output

        > perl -d db.pl > debugger .output

Loading DB routines from perl5db.pl version 1.27
Editor support available.

Enter h or `h h' for help, or `man perldebug' for more help.

main::(db.pl:3): print Config->myconfig;
  DB<1> c
Debugged program terminated.  Use q to quit or R to restart,
  use O inhibit_exit to avoid stopping after program termination,
  h q, h R or h O to get additional info.
  DB<1> q

        > diff ordinary.output debugger

No difference at all.

Richard Foley

Different output when run from the debugger vs. the command line
Shimon Bollinger
Mon, 15 May 2006 04:40:02 -0700
When I run the following script from the command line, I get different
output than when I run it with the debugger.

use Config qw(myconfig);
print Config->myconfig;

Here is the relevant differences in the output:

>From the debugger:
 uname='linux lxcert-i386.cern.ch 2.4.21-27.0.2.el.cernsmp #1 smp thu
jan 20 01:37:09 cet 2005 i686 i686 i386 gnulinux '

>From the command line:
 uname='linux lxc'

Why would this happen?

Perl and OS Info:
This is perl, v5.8.0 built for i386-linux-thread-multi (with 1
registered patch, see perl -V for more detail) 

Linux localhost.localdomain 2.4.21-37.ELsmp #1 SMP Wed Sep 7 13:28:55
EDT 2005 i686 i686 i386 GNU/Linux

Reply via email to