EUREKA (maybe) !

This evening I took the iPhone update to iOS 11.3, and just out of curiosity I 
decided to check out the iphone as an attached device in the file manager.  And 
I'm in.  I don't know why.  I did not use
idevicepair nor ifuse.  If I run ideviceinfo, I still get "ERROR: Could not 
connect to lockdownd, error code -3".

In the file manager I found that clicking on a thumbnail gave me the
photo.

Messing around in the command line, a call to "df" suggested that I look
at "/run/user/1000".

Going there I found a current datestamp on its subdirectory "gvfs" and within 
that a sole item
with robotic name "gphoto2:host=%5Busb%3A004%2C023%5D".

Inside that there is a single directory "DCIM" (less than I used to see
in iOS 10.3), but that has always been the place for photos.

Within DCIM there are subdirectories "100CLOUD" and "100APPLE".  I'm not
sure what that's about, but the photos in the first are older and are
all of size 3264x2448.  During the time period for the photos in
100CLOUD, I changed to a new phone, but the latest photos in there were
taken on the new phone.  In 100APPLE the photos are all of size
4032x3024.

I'm guessing that usb infra-structure invoked some gphoto infra-
structure, and that libimobiledevice is not in the picture, but I don't
know.

And for the moment I'm guessing that Apple has cleaned up its act with
iOS 11.3.

My Ubuntu is 16.04.4 LTS, and I'm running the Mate evolute of classic gnome.  
In the Mate GUI connecting the phone to a usb port causes an icon to appear on 
my desktop.  A right click on that
icon gives me an unmount option that I used before disconnecting the phone.

-- 
You received this bug notification because you are a member of Ubuntu
Desktop Bugs, which is subscribed to libimobiledevice in Ubuntu.
https://bugs.launchpad.net/bugs/1718554

Title:
  Need updated libimobiledevice to mount IOS 11 devices

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libimobiledevice/+bug/1718554/+subscriptions

-- 
desktop-bugs mailing list
desktop-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/desktop-bugs

Reply via email to