You have been subscribed to a public bug:

I'm running Ubuntu 18.04.2 desktop in a virtual machine under VMWare
Fusion Pro V11.1.0 on MacOS Mojave 10.14.5, all on a 15inch 2018 Macbook
Pro.

I've been running this Ubuntu 18.04.2 VM without problem for many months 
without problem.
Yesterday, I did 'sudo apt update; sudo apt upgrade'.  Upon rebooting, the 
system hangs immediately after displaying the splash screen.  I never see a 
login screen.  And I can't use Ctrl+Alt+F2 to navigate to a console/tty login.

I can SSH into the system however.

I've found that I can work around the hang/freeze if I uncomment the following 
line in /etc/gdm3/custom.conf;
#WaylandEnable=false

After uncommenting the WaylandEnable=false line and rebooting, then I
see the login prompt as expected and I can then log in and use the
system normally again.

After the 'apt upgrade' my system is running linux kernel 4.15.0-51, as
shown in this 'uname -a' output;

Linux ubuntuvm1 4.15.0-51-generic #55-Ubuntu SMP Wed May 15 14:27:21 UTC
2019 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a output;

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: xorg 1:7.7+19ubuntu7.1
ProcVersionSignature: Ubuntu 4.15.0-51.55-generic 4.15.18
Uname: Linux 4.15.0-51-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CompositorRunning: None
Date: Sun Jun  9 12:38:37 2019
DistUpgraded: Fresh install
DistroCodename: bionic
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GpuHangFrequency: This is the first time
GraphicsCard:
 VMware SVGA II Adapter [15ad:0405] (prog-if 00 [VGA controller])
   Subsystem: VMware SVGA II Adapter [15ad:0405]
InstallationDate: Installed on 2018-05-06 (399 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: VMware, Inc. VMware Virtual Platform
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-51-generic 
root=/dev/mapper/ubuntu--vg-root ro splash net.ifnames=0
SourcePackage: xorg
Symptom: display
Title: Xorg freeze
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 04/13/2018
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.name: 440BX Desktop Reference Platform
dmi.board.vendor: Intel Corporation
dmi.board.version: None
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: No Enclosure
dmi.chassis.version: N/A
dmi.modalias: 
dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd04/13/2018:svnVMware,Inc.:pnVMwareVirtualPlatform:pvrNone:rvnIntelCorporation:rn440BXDesktopReferencePlatform:rvrNone:cvnNoEnclosure:ct1:cvrN/A:
dmi.product.name: VMware Virtual Platform
dmi.product.version: None
dmi.sys.vendor: VMware, Inc.
version.compiz: compiz N/A
version.libdrm2: libdrm2 2.4.95-1~18.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.2.8-0ubuntu0~18.04.2
version.libgl1-mesa-glx: libgl1-mesa-glx 18.2.8-0ubuntu0~18.04.2
version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu4.2
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:18.0.1-1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

** Affects: mutter (Ubuntu)
     Importance: Undecided
         Status: Confirmed


** Tags: amd64 apport-bug bionic freeze ubuntu
-- 
Login screen never appears on vmwgfx but setting WaylandEnable=false fixes it
https://bugs.launchpad.net/bugs/1832138
You received this bug notification because you are a member of Ubuntu Desktop 
Bugs, which is subscribed to mutter in Ubuntu.

-- 
desktop-bugs mailing list
desktop-bugs@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/desktop-bugs

Reply via email to