On Tue, Aug 8, 2017 at 10:45 PM, mcatanz...@gnome.org wrote:
OK, I'm done sending emails. If you don't have a mail from me, then your module is probably fine.


Michael

Another update. Thanks to lots of help from lots of people, I'm down to just three known build failures. (There might be more hidden behind modules I failed to build last night, but probably not many.) Two are easy and just need new tarballs. There is only one real problem right now: simple-scan. Here is the build error:

../../../../releases/gnome-apps-3.25.90/simple-scan-3.25.90/src/app-window.vala:1441.95-1441.100: error: The name `code' does not exist in the context of `Pk.Error' result_text = _("Failed to install drivers (error code %d).").printf (e.code); ^^^^^^
Compilation failed: 1 error(s), 0 warning(s)
ninja: build stopped: subcommand failed.

The problem seems to be that in GNOME we have two different, competing packagekit-glib2.vapi files: one installed by PackageKit and one installed by vala. The one installed by vala has Error.code, but the one installed by PackageKit seems to take precedence, and it does not have Error.code. The two sets of bindings are really significantly/worryingly different. I'm really not sure what to make of this.

Since this might indicate a major issue somewhere in either the gobject-introspection or vala stacks, I don't think we should proceed until simple-scan is buildable.

Michael

_______________________________________________
desktop-devel-list mailing list
desktop-devel-list@gnome.org
https://mail.gnome.org/mailman/listinfo/desktop-devel-list

Reply via email to