on quantal i386, this is no more an issue on my system since a while.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-nouveau in Ubuntu.
https://bugs.launchpad.net/bugs/1033533

Title:
  Xorg crashed with SIGABRT: exaMemcpyBox with src=0x0 on nouveau with
  SW rendering

Status in “xserver-xorg-video-nouveau” package in Ubuntu:
  Confirmed

Bug description:
  Crash doing memcpy in EXA on nouveau, with software rendering
  activated.

  #8  <signal handler called>
  No symbol table info available.
  #9  __memcpy_sse2 () at ../sysdeps/x86_64/multiarch/../memcpy.S:72
  No locals.
  #10 0x00007f570e63684e in memcpy (__len=23, __src=0x0, __dest=0x7f5713877100) 
at /usr/include/x86_64-linux-gnu/bits/string3.h:52
  No locals.
  #11 exaMemcpyBox (pbox=pbox@entry=0x7fffef000de0, src=0x0, src_pitch=64, 
dst=0x7f5713877100 "", dst_pitch=24, pPixmap=<error reading variable: Unhandled 
dwarf expression opcode 0xfa>) at ../../exa/exa_migration_classic.c:59
          i = 16
          cpp = <optimized out>
          bytes = 23
  #12 0x00007f570e636d03 in exaCopyDirty (migrate=migrate@entry=0x7fffef000e40, 
pValidDst=0x7f5713dc3e40, pValidSrc=0x7f5713dc3e50, transfer=0x7f570f28b7f0 
<nouveau_exa_download_from_screen>, fallback_index=fallback_index@entry=1, 
sync=0x7f570e635780 <exaWaitSync>) at ../../exa/exa_migration_classic.c:240
          pPixmap = 0x7f5713dc3da0
          pExaPixmap = 0x7f5713dc3e00
          damage = <optimized out>
          CopyReg = {extents = {x1 = 0, y1 = 0, x2 = 23, y2 = 16}, data = 0x0}
          save_use_gpu_copy = 1
          save_pitch = 64
          pBox = 0x7fffef000de0
          nbox = 1
          access_prepared = 1
          need_sync = 0
  #13 0x00007f570e636f32 in exaCopyDirtyToSys 
(migrate=migrate@entry=0x7fffef000e40) at ../../exa/exa_migration_classic.c:285
          pPixmap = <optimized out>
          pExaScr = 0x7f5713877100
          pExaPixmap = 0x0
  #14 0x00007f570e63951a in exaPrepareAccessReg_mixed (pPixmap=0x7f5713dc3da0, 
index=<optimized out>, pReg=0x0) at ../../exa/exa_migration_mixed.c:254
          as_dst = 1
          pixmaps = {{as_dst = 0, as_src = 1, pPix = 0x7f5713dc3da0, pReg = 
0x0}}
          pExaPixmap = 0x7f5713dc3e00
          has_gpu_copy = <optimized out>
          success = <optimized out>

  [Original Report]
  The crash report started immediately after login.

  ProblemType: Crash
  DistroRelease: Ubuntu 12.10
  Package: xserver-xorg-core 2:1.12.99.902-0ubuntu1
  ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
  Uname: Linux 3.5.0-8-generic x86_64
  .tmp.unity.support.test.0:

  ApportVersion: 2.4-0ubuntu6
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  CompositorRunning: None
  CrashCounter: 1
  Date: Sun Aug  5 14:46:44 2012
  DistUpgraded: Fresh install
  DistroCodename: quantal
  DistroVariant: ubuntu
  DkmsStatus:
   virtualbox, 4.1.18, 3.5.0-6-generic, x86_64: installed
   virtualbox, 4.1.18, 3.5.0-8-generic, x86_64: installed
  ExecutablePath: /usr/bin/Xorg
  ExtraDebuggingInterest: Yes, if not too technical
  GraphicsCard:
   NVIDIA Corporation C61 [GeForce 6100 nForce 400] [10de:03d2] (rev a2) 
(prog-if 00 [VGA controller])
     Subsystem: NVIDIA Corporation Device [10de:cb84]
  InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120519)
  Lsusb:
   Bus 001 Device 002: ID 18ec:3399 Arkmicro Technologies Inc.
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  ProcCmdline: /usr/bin/X :0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 
-novtswitch -background none
  ProcEnviron:

  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-8-generic 
root=UUID=a80eff25-65c3-4db0-adad-31d8ea95823b ro quiet splash vt.handoff=7
  Renderer: Software
  Signal: 6
  SourcePackage: xorg-server
  StacktraceTop:
   ?? () from /lib/x86_64-linux-gnu/libc.so.6
   ?? () from /usr/lib/xorg/modules/libexa.so
   ?? () from /usr/lib/xorg/modules/libexa.so
   ?? () from /usr/lib/xorg/modules/libexa.so
   ?? () from /usr/lib/xorg/modules/libexa.so
  Title: Xorg crashed with SIGABRT
  UpgradeStatus: No upgrade log present (probably fresh install)
  UserGroups:

  dmi.bios.date: 09/22/2006
  dmi.bios.vendor: Phoenix Technologies, LTD
  dmi.bios.version: 6.00 PG
  dmi.board.name: NF-MCP61
  dmi.chassis.type: 3
  dmi.modalias: 
dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd09/22/2006:svn:pn:pvr:rvn:rnNF-MCP61:rvr:cvn:ct3:cvr:
  version.compiz: compiz 1:0.9.8+bzr3249-0ubuntu2
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.37-0ubuntu2
  version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.4-1ubuntu1
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.4-1ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.12.99.902-0ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-2~ubuntu1
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 
1:6.99.99~git20120713.6ef1ad6a-0ubuntu1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.20.2-1ubuntu1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.1-4~ubuntu1

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1033533/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to