*** This bug is a duplicate of bug 264336 ***
https://bugs.launchpad.net/bugs/264336
** This bug has been marked a duplicate of bug 264336
pgsql fails to start due to shared buffer setting greater than kernel allows
--
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to postgresql-9.1 in Ubuntu.
https://bugs.launchpad.net/bugs/1171583
Title:
Failed system call was shmget
Status in “postgresql-9.1” package in Ubuntu:
New
Bug description:
# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 13.04
Release: 13.04
Codename: raring
# uname -a
Linux think 3.8.0-18-generic #28-Ubuntu SMP Thu Apr 11 19:38:55 UTC 2013
x86_64 x86_64 x86_64 GNU/Linux
2013-04-19 22:35:34 MSK LOG: shutting down
2013-04-19 22:35:34 MSK LOG: database system is shut down
2013-04-19 22:35:50 MSK FATAL: could not create shared memory segment:
Invalid argument
2013-04-19 22:35:50 MSK DETAIL: Failed system call was shmget(key=5432001,
size=41263104, 03600).
2013-04-19 22:35:50 MSK HINT: This error usually means that PostgreSQL's
request for a shared memory segment exceeded your kernel's SHMMAX parameter.
You can either reduce the request size or reconfigure the kernel with larger
SHMMAX. To reduce the request size (currently 41263104 bytes), reduce
PostgreSQL's shared memory usage, perhaps by reducing shared_buffers or
max_connections.
If the request size is already small, it's possible that it is less
than your kernel's SHMMIN parameter, in which case raising the request size or
reconfiguring SHMMIN is called for.
The PostgreSQL documentation contains more information about shared
memory configuration.
# sysctl kernel.shmmax
kernel.shmmax = 268435456
ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: postgresql-9.1 9.1.9-1ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-18.28-generic 3.8.6
Uname: Linux 3.8.0-18-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Mon Apr 22 23:10:50 2013
InstallationDate: Installed on 2013-04-14 (8 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130402.1)
MarkForUpload: True
SourcePackage: postgresql-9.1
UpgradeStatus: No upgrade log present (probably fresh install)
To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/postgresql-9.1/+bug/1171583/+subscriptions
--
Mailing list: https://launchpad.net/~desktop-packages
Post to : [email protected]
Unsubscribe : https://launchpad.net/~desktop-packages
More help : https://help.launchpad.net/ListHelp