Public bug reported:
* Starting PostgreSQL 9.1 database server
* The PostgreSQL server failed to start. Please check the log output:
2013-12-11 16:59:58 PST LOG: peer authentication is only supported on local
sockets
2013-12-11 16:59:58 PST CONTEXT: line 93 of configuration file
"/etc/postgresql/9.1/main/pg_hba.conf"
2013-12-11 16:59:58 PST FATAL: could not load pg_hba.conf
[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql-9.1:
postgresql-9.1 depends on postgresql-common (>= 115~); however:
Package postgresql-common is not configured yet.
dpkg: error processing postgresql-9.1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-9.1; however:
Package postgresql-9.1 is not configured yet.
dpkg: error processing postgresql (--configure):
dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: postgresql-common 129ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-57.87-generic-pae 3.2.52
Uname: Linux 3.2.0-57-generic-pae i686
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: i386
Date: Wed Dec 11 17:00:04 2013
DuplicateSignature: package:postgresql-common:129ubuntu1:subprocess installed
post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit
status 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: postgresql-common
Title: package postgresql-common 129ubuntu1 failed to install/upgrade:
subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
** Affects: postgresql-common (Ubuntu)
Importance: Undecided
Status: New
** Tags: apport-package i386 need-duplicate-check precise
--
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to postgresql-common in Ubuntu.
https://bugs.launchpad.net/bugs/1260136
Title:
cannot configure postgresql;dependency problem for package
postgresql-9.1
Status in “postgresql-common” package in Ubuntu:
New
Bug description:
* Starting PostgreSQL 9.1 database server
* The PostgreSQL server failed to start. Please check the log output:
2013-12-11 16:59:58 PST LOG: peer authentication is only supported on local
sockets
2013-12-11 16:59:58 PST CONTEXT: line 93 of configuration file
"/etc/postgresql/9.1/main/pg_hba.conf"
2013-12-11 16:59:58 PST FATAL: could not load pg_hba.conf
[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of postgresql-9.1:
postgresql-9.1 depends on postgresql-common (>= 115~); however:
Package postgresql-common is not configured yet.
dpkg: error processing postgresql-9.1 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of postgresql:
postgresql depends on postgresql-9.1; however:
Package postgresql-9.1 is not configured yet.
dpkg: error processing postgresql (--configure):
dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: postgresql-common 129ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-57.87-generic-pae 3.2.52
Uname: Linux 3.2.0-57-generic-pae i686
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: i386
Date: Wed Dec 11 17:00:04 2013
DuplicateSignature: package:postgresql-common:129ubuntu1:subprocess installed
post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error
exit status 1
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386
(20120423)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: postgresql-common
Title: package postgresql-common 129ubuntu1 failed to install/upgrade:
subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/postgresql-common/+bug/1260136/+subscriptions
--
Mailing list: https://launchpad.net/~desktop-packages
Post to : [email protected]
Unsubscribe : https://launchpad.net/~desktop-packages
More help : https://help.launchpad.net/ListHelp