Public bug reported:

The current build of libnettle6 does not have AES-NI enabled. There's
two configure options for enabling it:

--enable-x86-aesni: Use AES-NI instructions instead of the standard 
implementation. This will break on systems that don't have AES-NI.
--enable-fat: Build a "fat" library that has the standard implementation and 
the AES-NI implementation. This allows the library to continue working on older 
systems while providing faster performance on systems that have AES-NI.

Note that Nettle's AES-NI implementation as of v3.2 is only supported on
amd64, not i386, so this would only affect the 64-bit package.

** Affects: nettle (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nettle in Ubuntu.
https://bugs.launchpad.net/bugs/1624485

Title:
  Nettle: Enable AES-NI instructions on amd64.

Status in nettle package in Ubuntu:
  New

Bug description:
  The current build of libnettle6 does not have AES-NI enabled. There's
  two configure options for enabling it:

  --enable-x86-aesni: Use AES-NI instructions instead of the standard 
implementation. This will break on systems that don't have AES-NI.
  --enable-fat: Build a "fat" library that has the standard implementation and 
the AES-NI implementation. This allows the library to continue working on older 
systems while providing faster performance on systems that have AES-NI.

  Note that Nettle's AES-NI implementation as of v3.2 is only supported
  on amd64, not i386, so this would only affect the 64-bit package.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nettle/+bug/1624485/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to