I was able to fix this problem on a MacBook Pro 4,1 with a GeForce 8600M GT by 
following these instructions:

In this case, installing the current version of Ubuntu (16.04.1) via USB
with a GUID partition table was not a problem.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to nvidia-graphics-drivers-304 in Ubuntu.

  legacy nvidia drivers fail to work with latest kernel

Status in nvidia-graphics-drivers-304 package in Ubuntu:
Status in nvidia-graphics-drivers-340 package in Ubuntu:

Bug description:
  i have a MacBookPro3,1 with a NVIDIA Corporation G84M [GeForce 8600M
  GT] (rev a1) video card. while in ubuntu 15.10 everything worked fine,
  after the upgrade in 16.04 the legacy nvidia-304 drivers do not. the
  X11 fails to start, the relevant lines in the /var/log/Xorg.0.log file

  [  3021.745] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at 
PCI:1:0:0.  Please
  [  3021.745] (EE) NVIDIA(0):     check your system's kernel log for 
additional error
  [  3021.745] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common 
Problems in the
  [  3021.745] (EE) NVIDIA(0):     README for additional information.
  [  3021.745] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
  [  3021.745] (EE) NVIDIA(0): Failing initialization of X screen 0
  [  3021.745] (II) UnloadModule: "nvidia"

  and the journalctl --dmesg gives

  kernel: NVRM: failed to copy vbios to system memory.
  kernel: NVRM: RmInitAdapter failed! (0x30:0xffffffff:867)
  kernel: NVRM: rm_init_adapter(0) failed

  nevertheless, the nvidia kernel module is loaded without a problem.

  i also tried more recent versions of nvidia-X but without success.
  they either fail with the same messages as above or they do not
  support the video card.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: linux-image-4.4.0-6-generic 4.4.0-6.21
  ProcVersionSignature: Ubuntu 4.4.0-6.21-generic 4.4.1
  Uname: Linux 4.4.0-6-generic x86_64
  NonfreeKernelModules: nvidia
  ApportVersion: 2.20-0ubuntu3
  Architecture: amd64
  AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/snd/by-path', 
'/dev/snd/hwC0D0', '/dev/snd/pcmC0D2c', '/dev/snd/pcmC0D1c', 
'/dev/snd/pcmC0D1p', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', 
'/dev/snd/controlC0', '/dev/snd/seq', '/dev/snd/timer'] failed with exit code 1:
   country AW: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5170 - 5250 @ 80), (N/A, 20), (N/A)
        (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
  Date: Fri Feb 19 18:05:07 2016
  HibernationDevice: RESUME=UUID=484d04a2-0891-47bb-b890-ee3ab0189ef7
  InstallationDate: Installed on 2016-02-17 (2 days ago)
  InstallationMedia: Ubuntu-Server 15.10 "Wily Werewolf" - Release amd64 
  MachineType: Apple Inc. MacBookPro3,1
  ProcFB: 0 EFI VGA
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-6-generic.efi.signed 
root=UUID=fddff8cb-9428-47b7-a215-034c4b79c0fe ro
  PulseList: Error: command ['pacmd', 'list'] failed with exit code 1: No 
PulseAudio daemon running, or not running as session daemon.
   linux-restricted-modules-4.4.0-6-generic N/A
   linux-backports-modules-4.4.0-6-generic  N/A
   linux-firmware                           1.156
  SourcePackage: linux
  UpgradeStatus: Upgraded to xenial on 2016-02-17 (1 days ago)
  dmi.bios.date: 03/05/08
  dmi.bios.vendor: Apple Inc.
  dmi.bios.version: MBP31.88Z.0070.B07.0803051658
  dmi.board.asset.tag: Base Board Asset Tag
  dmi.board.name: Mac-F4238BC8
  dmi.board.vendor: Apple Inc.
  dmi.board.version: PVT
  dmi.chassis.asset.tag: Asset Tag#
  dmi.chassis.type: 2
  dmi.chassis.vendor: Apple Inc.
  dmi.chassis.version: Mac-F4238BC8
  dmi.product.name: MacBookPro3,1
  dmi.product.version: 1.0
  dmi.sys.vendor: Apple Inc.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to