`gnome-open somefile.txt` shows the icon in the launcher, blinking.
After some time (aout 30s) the icon goes away and the gedit process is
still running.

Starting gedit in standalone mode doesn't help either: the icon is not
shown in the launcher, and gedit terminates with the following issue:

    `Failed to register: Timeout was reached`

I also tried:
- running as root --> `gedit -s` doesn't terminate
- `apt-get remove gedit` then `apt-get install gedit` --> `gedit -s` doesn't 
terminate
- `dpkg-reconfigure gedit` --> `gedit -s` doesn't terminate

`gedit -s` doesn't respond to Ctrl-C which means that the process is
stuck in kernel mode, in some I/O or system call and doesn't return to
user mode. Only the KILL signal will terminate it.

As a result I can attach gdb to the `gedit -s` process but cannot debug it:
```
$ gdb -p 11414
GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.04) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word".
Attaching to process 11414
^C^C^C^C^C^C^C^C^C
```

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gedit in Ubuntu.
https://bugs.launchpad.net/bugs/1625819

Title:
  gedit is stuck starting, no window is shown

Status in gedit package in Ubuntu:
  New

Bug description:
  I use VPN to log to my workplace which uses proxy.
  I don't know if the proxy is an issue, but with or without $http_proxy set, 
gedit won't start properly.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: gedit 3.18.3-0ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
  Uname: Linux 4.4.0-38-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CurrentDesktop: Unity
  Date: Tue Sep 20 22:10:49 2016
  InstallationDate: Installed on 2016-06-26 (86 days ago)
  InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 
(20160420.1)
  SourcePackage: gedit
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/1625819/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to