Tried suggestion from @pedroavila95 without luck
ElementaryOS Freya

sudo apt-add-repository ppa:oibaf/graphics-drivers
sudo apt-get update
sudo apt-get dist-upgrade
(then reboot)

Downloaded all updated, etc. still not working

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-intel in Ubuntu.

  Mouse cursor lost when unlocking with Intel graphics

Status in elementary OS:
  Fix Released
Status in xf86-video-intel:
Status in xserver-xorg-video-intel package in Ubuntu:
  Fix Released
Status in xserver-xorg-video-intel-lts-xenial package in Ubuntu:
Status in xserver-xorg-video-intel source package in Xenial:
  Fix Released
Status in xserver-xorg-video-intel package in Debian:
  Fix Released

Bug description:
  [Relevant details]
  This bug also affects Trusty and all distributions based on it, like 
Elementary OS Freya.

  Mouse cursor is no longer visible after VT-switch for systems with Intel 

  Switching VTs again may cause the cursor to become visible again.
  - Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7)

  This is often observed in systems that lock the session and return to
  the greeter (including at least Xubuntu, Ubuntu Mate, and elementary

  [Test Case]
  (Requires a lightdm-based screen locking solution)
  1. Start a new session.
  2. Lock your screen.
  2a. You are redirected to the lightdm greeter.
  3. Login/Unlock your session.
  4. Cursor is no longer visible.

  [Regression Potential]
  remains to be seen


  [Original Report]
  Cursor is visible at unlock screen either after returning from suspend or 
just locking.

  After unlocking screen cursor is invisible.

  Changing to vt1 then back to vt7 (ctrl+alt+f1 then ctrl+alt+f7) cursor


  no matter if you suspend or sleep, to swap or disk when you return
  from it, the mouse cursor is missing.    you can still move the mouse
  and you can see (because it highlights the window) as you move it
  around.   But the cursor is not displayed on the screen.

  i am using a lenovo W540 laptop.   I downloaded the latest beta on
  april 8 2016.

  this is xubuntu using the xfce window manager.

  the cursor does return if i log off and log back in, but that actually 
defeats the purpose of going to sleep.
  ApportVersion: 2.20.1-0ubuntu1
  Architecture: amd64
  DistroRelease: Ubuntu 16.04
  InstallationDate: Installed on 2016-04-08 (2 days ago)
  InstallationMedia: Xubuntu 16.04 LTS "Xenial Xerus" - Beta amd64 (20160323)
  NonfreeKernelModules: nvidia_uvm nvidia_modeset nvidia
  Package: light-locker 1.7.0-2ubuntu1
  PackageArchitecture: amd64
   PATH=(custom, no user)
  ProcVersionSignature: Ubuntu 4.4.0-18.34-generic 4.4.6
  Tags:  xenial
  Uname: Linux 4.4.0-18-generic x86_64
  UpgradeStatus: No upgrade log present (probably fresh install)

  _MarkForUpload: True

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to