Yes it sounds/looks like a signalling frequency problem if not a cable

Check out bug 1606103 where some frequency problems with the modesetting
driver are being investigated.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg-server in Ubuntu.

  1920x1080 HDMI output is corrupted in 16.04

Status in xorg-server package in Ubuntu:

Bug description:
  Ever since upgrading to 16.04 from 14.04 on my Lenovo x230 the HDMI
  output to a Benq W1070 is corrupted if run at 1920x1080 (native
  resolution). At 1280x720 the display looks fine. Looking at similar
  reports for other graphics cards it seems similar to cases when the
  frequency is too low. I've tested that the projector still works fine
  with the same cable and another computer. I've attached a photo of the
  kind of corruption that shows up on screen. It's mostly green/magenta
  pixels sprinkled across the screen.

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: xorg 1:7.7+13ubuntu3
  ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
  Uname: Linux 4.4.0-38-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2.1
  Architecture: amd64
  CompizPlugins: No value set for 
  CompositorRunning: compiz
  CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
  CompositorUnredirectFSW: true
  CurrentDesktop: Unity
  Date: Sat Oct  8 19:38:39 2016
  DistUpgraded: 2016-08-07 01:11:54,340 DEBUG icon theme changed, re-reading
  DistroCodename: xenial
  DistroVariant: ubuntu
   virtualbox, 5.0.24, 4.4.0-31-generic, x86_64: installed
   virtualbox, 5.0.24, 4.4.0-38-generic, x86_64: installed
  ExtraDebuggingInterest: Yes
   Intel Corporation 3rd Gen Core processor Graphics Controller [8086:0166] 
(rev 09) (prog-if 00 [VGA controller])
     Subsystem: Lenovo 3rd Gen Core processor Graphics Controller [17aa:21fa]
  InstallationDate: Installed on 2014-05-03 (889 days ago)
  InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
  MachineType: LENOVO 23252QG
  ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-38-generic 
root=UUID=9018e190-86bb-4fbf-a348-d47ea769640f ro quiet splash vt.handoff=7
  SourcePackage: xorg
  Symptom: display
  UpgradeStatus: Upgraded to xenial on 2016-08-07 (62 days ago) 05/24/2012
  dmi.bios.vendor: LENOVO
  dmi.bios.version: G2ET31WW (1.11 )
  dmi.board.asset.tag: Not Available 23252QG
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
dmi:bvnLENOVO:bvrG2ET31WW(1.11):bd05/24/2012:svnLENOVO:pn23252QG:pvrThinkPadX230:rvnLENOVO:rn23252QG:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable: 23252QG
  dmi.product.version: ThinkPad X230
  dmi.sys.vendor: LENOVO
  version.compiz: compiz 1:
  version.ia32-libs: ia32-libs N/A
  version.libdrm2: libdrm2 2.4.67-1ubuntu0.16.04.2
  version.libgl1-mesa-dri: libgl1-mesa-dri 11.2.0-1ubuntu2.2
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 11.2.0-1ubuntu2.2
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
  xserver.bootTime: Wed Oct  5 10:26:16 2016
  xserver.configfile: default
  xserver.logfile: /var/log/Xorg.0.log
   product id                                 728 
   vendor                                     LGD
  xserver.version: 2:1.18.3-1ubuntu2.3

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to