Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xdiagnose (Ubuntu)
       Status: New => Confirmed

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xdiagnose in Ubuntu.
https://bugs.launchpad.net/bugs/1576842

Title:
  None of the recovery options from boot-time low-graphics mode work

Status in xdiagnose package in Ubuntu:
  Confirmed

Bug description:
  In Ubuntu 16.04 x86_64, I accidentally installed the nvidia driver on
  a machine that actually has an intel graphics controller. This caused
  two different failure modes in the time I was trying to figure out
  what was wrong: sometimes the X server was unable to start at all, and
  other times it loaded both nvidia and intel drivers, successfully
  deduced that nvidia shouldn't have been loaded and unloaded it, and
  successfully displayed the lightdm login screen, but then wouldn't let
  me log in because the X server had failed to configure opengl
  properly, probably because installing the nvidia driver caused the X
  server to be configured to use the wrong mesa library.

  This bug report is about the first failure mode mentioned above, i.e.,
  the X server was unable to start at all on boot.

  Instead, I was presented with a dialog that said "The system is
  running in low-graphics mode" and offered me several choices for what
  to do about it. I believe that this dialog was displayed by xdiagnose
  (version 3.8.4), which is why I'm filing this report for that package.
  If I'm wrong, please redirect the bug report as appropriate.

  The point of this bug report is that none of the recovery options
  presented by the dialogs worked. In particular:

  * Selecting "Try running with default graphics mode" didn't work: the
  screen flashed several times and then settled on a black screen
  showing nothing but the results of the boot-time fsck of the root
  filesystem. At that point, I couldn't switch VTs or anything else; the
  system was simply hosed and power-cycling was the only option.

  * Selecting "Reconfigure graphics" (either "Use default (generic)
  configuration" or "Use your backed-up configuration) just flashed and
  returned me to the same screen asking me again which configuration to
  use.

  * Selecting "Troubleshoot the error" and then "Edit configuration
  file" didn't work; I was not presented with an editor window, but
  rather I was simply returned to the same prompt.

  * "Exit to console login" didn't work; it had the same fsck-screen
  failure mode described above for "Try running with default graphics
  mode".

  I also tried booting in recovery mode and selecting failsafe graphics
  mode from the recovery menu. This didn't work either. See the attached
  screenshot for what I got when I tried that. In particular, note the
  "cp: cannot stat '/etc/X11/xorg.conf': No such file or directory" and
  "/usr/share/xdiagnose/failsafeXinit: line 117: return: zenity: numeric
  argument required" error messages.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xdiagnose/+bug/1576842/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to