This is the 'bug' in the upstream, it seems that when Thunderbird is
configured NOT to fetch messages from Imap folders by default, adding
new headers to search by won't work. One has to unsubscribe and then re-
subscribe again to the particular folder (so that TB re-downloads all
the headers) for the search to work.

Sometimes it is enough to just repair the folder in question, but I
haven't figured out why on occasion this won't work.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to thunderbird in Ubuntu.

  Searching messages by arbitrary headers sometimes doesn't work

Status in thunderbird package in Ubuntu:

Bug description:
  I have a folder with emails from Launchpad regarding Launchpad bug.
  All of those emails have, among others, this two headers:


  I added both of those fields as a custom fields inside Thunderbird's
  'Customized' headers (in the Search window).

  I've got over 10k emails in that folder, and all of the emails contain
  both those headers, and a lot of them contain single letter 'a' as a
  header content.

  When I create a search that looks like this:

  X-Launchpad-Bug-Commenters contains "a"

  Thunderbird returns almost all emails.

  But, when I create a search that looks like this:

  X-Launchpad-Bug-Reporter contains "a"

  no emails are returned, although there is a lot of emails whose "X
  -Launchpad-Bug-Reporter" contains an 'a'.

  This is Thunderbird in trusty:
  mario@MIKE ~> apt-cache policy thunderbird
    Installed: 1:45.3.0+build1-0ubuntu0.14.04.4
    Candidate: 1:45.3.0+build1-0ubuntu0.14.04.4

  I have also downloaded/installed Thunderbird from the beta-ppa
  (ppa:mozillateam/thunderbird-next), 1:50.0~b1+build2-0ubuntu0.14.04.1,
  and was able to reproduce the above mentioned issue.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: thunderbird 1:45.3.0+build1-0ubuntu0.14.04.4
  ProcVersionSignature: Ubuntu 3.13.0-96.143-generic 3.13.11-ckt39
  Uname: Linux 3.13.0-96-generic x86_64
  AddonCompatCheckDisabled: False
  ApportVersion: 2.14.1-0ubuntu3.21
  Architecture: amd64
   /dev/snd/controlC0:  mario      5345 F.... pulseaudio
  BuildID: 20160831174751
  Channel: Unavailable
  CurrentDesktop: MATE
  Date: Mon Oct 10 16:03:09 2016
  ForcedLayersAccel: False
   Enigmail - {847b3a00-7ab1-11d4-8f02-006008948af5}
   English (GB) Language Pack -
   Thunderbird (default) - {972ce4c6-7e08-4474-a285-3208198ce6fd}
  InstallationDate: Installed on 2014-12-16 (663 days ago)
  InstallationMedia: Ubuntu MATE 14.04.1 "Trusty Tahr" - final amd64 (20141111)
   default via dev wlan1  proto static dev lxcbr0  proto kernel  scope link  src dev wlan1  proto kernel  scope link  src  
metric 9 dev virbr1  proto kernel  scope link  src dev virbr0  proto kernel  scope link  src
  MostRecentCrashID: bp-04321c15-607b-43fc-a91c-e73792140903
   IcedTea-Web Plugin (using IcedTea-Web 1.5.3 (1.5.3-0ubuntu0.14.04.1)) - 
   Google Talk Plugin - /opt/google/talkplugin/ 
   Google Talk Plugin Video Renderer - /opt/google/talkplugin/ 
   Shockwave Flash - /usr/lib/flashplugin-installer/
  Profiles: Profile0 (Default) - LastVersion=45.3.0/20160831174751 (In use)
   icedtea-7-plugin  1.5.3-0ubuntu0.14.04.1
  RunningIncompatibleAddons: True
  SourcePackage: thunderbird
  SubmittedCrashIDs: bp-04321c15-607b-43fc-a91c-e73792140903
  UpgradeStatus: No upgrade log present (probably fresh install) 07/18/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8DET69WW (1.39 )
  dmi.board.asset.tag: Not Available 42904XU
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
dmi:bvnLENOVO:bvr8DET69WW(1.39):bd07/18/2013:svnLENOVO:pn42904XU:pvrThinkPadX220:rvnLENOVO:rn42904XU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable: 42904XU
  dmi.product.version: ThinkPad X220
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:

Mailing list:
Post to     :
Unsubscribe :
More help   :

Reply via email to