This is the 'bug' in the upstream, it seems that when Thunderbird is
configured NOT to fetch messages from Imap folders by default, adding
new headers to search by won't work. One has to unsubscribe and then re-
subscribe again to the particular folder (so that TB re-downloads all
the headers) for the search to work.

Sometimes it is enough to just repair the folder in question, but I
haven't figured out why on occasion this won't work.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to thunderbird in Ubuntu.
https://bugs.launchpad.net/bugs/1631972

Title:
  Searching messages by arbitrary headers sometimes doesn't work

Status in thunderbird package in Ubuntu:
  New

Bug description:
  I have a folder with emails from Launchpad regarding Launchpad bug.
  All of those emails have, among others, this two headers:

  X-Launchpad-Bug-Reporter
  X-Launchpad-Bug-Commenters

  I added both of those fields as a custom fields inside Thunderbird's
  'Customized' headers (in the Search window).

  I've got over 10k emails in that folder, and all of the emails contain
  both those headers, and a lot of them contain single letter 'a' as a
  header content.

  When I create a search that looks like this:

  X-Launchpad-Bug-Commenters contains "a"

  Thunderbird returns almost all emails.

  But, when I create a search that looks like this:

  X-Launchpad-Bug-Reporter contains "a"

  no emails are returned, although there is a lot of emails whose "X
  -Launchpad-Bug-Reporter" contains an 'a'.

  This is Thunderbird in trusty:
  mario@MIKE ~> apt-cache policy thunderbird
  thunderbird:
    Installed: 1:45.3.0+build1-0ubuntu0.14.04.4
    Candidate: 1:45.3.0+build1-0ubuntu0.14.04.4

  I have also downloaded/installed Thunderbird from the beta-ppa
  (ppa:mozillateam/thunderbird-next), 1:50.0~b1+build2-0ubuntu0.14.04.1,
  and was able to reproduce the above mentioned issue.

  ProblemType: Bug
  DistroRelease: Ubuntu 14.04
  Package: thunderbird 1:45.3.0+build1-0ubuntu0.14.04.4
  ProcVersionSignature: Ubuntu 3.13.0-96.143-generic 3.13.11-ckt39
  Uname: Linux 3.13.0-96-generic x86_64
  AddonCompatCheckDisabled: False
  ApportVersion: 2.14.1-0ubuntu3.21
  Architecture: amd64
  AudioDevicesInUse:
   USER        PID ACCESS COMMAND
   /dev/snd/controlC0:  mario      5345 F.... pulseaudio
  BuildID: 20160831174751
  Channel: Unavailable
  CurrentDesktop: MATE
  Date: Mon Oct 10 16:03:09 2016
  ForcedLayersAccel: False
  IncompatibleExtensions:
   Enigmail - {847b3a00-7ab1-11d4-8f02-006008948af5}
   English (GB) Language Pack - langpack-en...@thunderbird.mozilla.org
   Thunderbird (default) - {972ce4c6-7e08-4474-a285-3208198ce6fd}
  InstallationDate: Installed on 2014-12-16 (663 days ago)
  InstallationMedia: Ubuntu MATE 14.04.1 "Trusty Tahr" - final amd64 (20141111)
  IpRoute:
   default via 192.168.1.1 dev wlan1  proto static 
   10.0.3.0/24 dev lxcbr0  proto kernel  scope link  src 10.0.3.1 
   192.168.1.0/24 dev wlan1  proto kernel  scope link  src 192.168.1.138  
metric 9 
   192.168.100.0/24 dev virbr1  proto kernel  scope link  src 192.168.100.1 
   192.168.122.0/24 dev virbr0  proto kernel  scope link  src 192.168.122.1
  MostRecentCrashID: bp-04321c15-607b-43fc-a91c-e73792140903
  Plugins:
   IcedTea-Web Plugin (using IcedTea-Web 1.5.3 (1.5.3-0ubuntu0.14.04.1)) - 
/usr/lib/jvm/java-7-openjdk-amd64/jre/lib/amd64/IcedTeaPlugin.so 
(icedtea-7-plugin)
   Google Talk Plugin - /opt/google/talkplugin/libnpgoogletalk.so 
(google-talkplugin)
   Google Talk Plugin Video Renderer - /opt/google/talkplugin/libnpo1d.so 
(google-talkplugin)
   Shockwave Flash - /usr/lib/flashplugin-installer/libflashplayer.so
  PrefSources:
   prefs.js
   
[Profile]/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults/preferences/enigmail.js
  Profiles: Profile0 (Default) - LastVersion=45.3.0/20160831174751 (In use)
  RelatedPackageVersions:
   icedtea-7-plugin  1.5.3-0ubuntu0.14.04.1
   google-talkplugin 5.41.3.0-1
  RunningIncompatibleAddons: True
  SourcePackage: thunderbird
  SubmittedCrashIDs: bp-04321c15-607b-43fc-a91c-e73792140903
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 07/18/2013
  dmi.bios.vendor: LENOVO
  dmi.bios.version: 8DET69WW (1.39 )
  dmi.board.asset.tag: Not Available
  dmi.board.name: 42904XU
  dmi.board.vendor: LENOVO
  dmi.board.version: Not Available
  dmi.chassis.asset.tag: No Asset Information
  dmi.chassis.type: 10
  dmi.chassis.vendor: LENOVO
  dmi.chassis.version: Not Available
  dmi.modalias: 
dmi:bvnLENOVO:bvr8DET69WW(1.39):bd07/18/2013:svnLENOVO:pn42904XU:pvrThinkPadX220:rvnLENOVO:rn42904XU:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
  dmi.product.name: 42904XU
  dmi.product.version: ThinkPad X220
  dmi.sys.vendor: LENOVO

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1631972/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to