I work on Ubuntu 16.04 with all recent updates, but I still keep getting
a series of this same messages:

"Unencrypted private keys are insecure - The selected private key does
not appear to be protected by a password."

when I edit settings to the company's WiFi:
Security:WPA Enterprise
Authentication: TLS
+ password protected key

When I "okey" through all the messages and try to connect to the WiFi -
I wait some time and then get the messages all over again.

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to network-manager in Ubuntu.

  Unencrypted private keys are insecure error reported even when key is

Status in NetworkManager:
  Fix Released
Status in network-manager package in Ubuntu:

Bug description:
  When I enter an EAP-TLS wifi config, I get the error:

  "Unencrypted private keys are insecure
  The selected private key does not appear to be protected by a password.  This 
could allow your security credentials to be compromised.  Please select a 
password-protected private key.

  (You can password-protect your private key with openssl)"

  I have verified that my key is, in fact, encrypted, and I have tried
  using both des3 and aes256. I have also verified the password used to
  encrypt the key.

  For a while, it wouldn't even let me save the config. I managed to
  save it eventually, but now when I try to connect to the saved
  connection, I get the same error.

  I am on Ubuntu mate 16.04

  network-manager 1.1.93

  ProblemType: Bug
  DistroRelease: Ubuntu 16.04
  Package: network-manager 1.1.93-0ubuntu4
  ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
  Uname: Linux 4.4.0-21-generic x86_64
  ApportVersion: 2.20.1-0ubuntu2
  Architecture: amd64
  CurrentDesktop: MATE
  Date: Fri Apr 22 13:25:16 2016
  InstallationDate: Installed on 2015-08-19 (246 days ago)
  InstallationMedia: Ubuntu-MATE 15.04 "Vivid Vervet" - Release amd64 
   default via dev eth1  proto static  metric 100 dev eth1  scope link  metric 1000 dev eth1  proto kernel  scope link  src  
metric 100
  SourcePackage: network-manager
  UpgradeStatus: Upgraded to xenial on 2016-04-22 (0 days ago)
   DEVICE  TYPE      STATE         DBUS-PATH                                  
CONNECTION          CON-UUID                              CON-PATH              
   eth1    ethernet  connected     /org/freedesktop/NetworkManager/Devices/2  
Wired connection 1  ed50d4f9-c810-4be0-b06c-8acd58015c50  
   wlan0   wifi      disconnected  /org/freedesktop/NetworkManager/Devices/1  
--                  --                                    --                    
   eth0    ethernet  unavailable   /org/freedesktop/NetworkManager/Devices/3  
--                  --                                    --                    
   lo      loopback  unmanaged     /org/freedesktop/NetworkManager/Devices/0  
--                  --                                    --
  nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 
2: Error: Object 'nm' is unknown, try 'nmcli help'.

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to