This bug was fixed in the package im-config - 0.29-1ubuntu12.3

---------------
im-config (0.29-1ubuntu12.3) xenial-proposed; urgency=medium

  * debian/patches/fix-uim-qt5.patch:
    - Fix uim Qt5 immodule path (LP: #1642001).
  * debian/patches/gcin-qt5.patch:
    - Add gcin Qt5 immodule (LP: #1482938).

 -- Gunnar Hjalmarsson <gunna...@ubuntu.com>  Wed, 16 Nov 2016 11:14:00
+0100

** Changed in: im-config (Ubuntu Xenial)
       Status: Fix Committed => Fix Released

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to im-config in Ubuntu.
https://bugs.launchpad.net/bugs/1482938

Title:
  im-config gcin qt5

Status in im-config package in Ubuntu:
  Fix Released
Status in im-config source package in Xenial:
  Fix Released
Status in im-config source package in Yakkety:
  Fix Released
Status in im-config package in Debian:
  Fix Released

Bug description:
  [Impact]

  missing

  QT_IM_MODULE=gcin

  in /usr/share/im-config/data/26_gcin.rc

  QT5 needs this.

  Fix uploaded to yakkety queue; xenial patch attached to bug #1642001.

  [Test Case]

  After the change, this command:

  grep -A3 QT_IM_MODULE /usr/share/im-config/data/26_gcin.rc

  should output:

  QT_IM_MODULE=xim
  # use immodule when available for Qt5
  for IM_CONFIG_MARKER in 
/usr/lib/*/qt5/plugins/platforminputcontexts/libgcinplatforminputcontextplugin.so
 ; do
      if [ -e $IM_CONFIG_MARKER ]; then
          QT_IM_MODULE=gcin
          break
      fi
  done

  [Regression Potential]

  None.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/im-config/+bug/1482938/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to