Could somebody test on xenial?

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gtk+2.0 in Ubuntu.
https://bugs.launchpad.net/bugs/1576424

Title:
  Gimp crashes with text tool & caps lock

Status in GTK+:
  Fix Released
Status in gtk+2.0 package in Ubuntu:
  Fix Released
Status in gtk+2.0 source package in Xenial:
  Fix Committed
Status in gtk+2.0 source package in Yakkety:
  Fix Released

Bug description:
  [Impact]

  Gimp crashes with a segfault when I use caps lock while renaming a
  layer. It is possible Caps lock causes crashes in other events also.

  [Test Case]

  Steps to reproduce:

  1. Open a new blank gimp document
  2. select the text tool
  3. type a couple of words of text (gimp will create a text layer above the 
background layer)
  4. with the text tool still selected, click on the background layer (just to 
move away from the text layer)
  5. now double click on the text layer to rename the layer (layer name gets 
highlighted)
  6. press the caps lock key
  7. click on the background layer again (without renaming or doing anything to 
the text layer)
  Now repeat steps 5 and 6.
  Gimp crashes.

  [Regression Potential]

  None expected. The patch used has been taken from upstream
  development.

  
https://git.gnome.org/browse/gtk%2B/commit/?id=2811221d7039bd82265ce36a1b0dd9a0eeb431ad

  Packages for Xenial and Yakkety have been built in a PPA and
  regression tested.

  [ Other Info ]

  I can force this to happen every time I launch Gimp. Rebooting makes
  no difference. It seems to be the second time I press caps lock that
  forces the crash. I tried launching Gimp with caps lock on vs caps
  lock off, but I don't believe it made any difference. I can force a
  crash every time following the above sequence.

  I deleted my gimp preferences folder then rebooted for good measure.
  Gimp created a fresh preferences folder, but it hasn't solved the
  problem. I was originally in single window mode, but the new
  preferences folder put me back to multi window, but it crashes either
  way.

  I ran dmesg | tail after the crash and got the following line:

  gimp-2.8[2976]: segfault at 14 ip 00007ff5100e0cd9 sp 00007ffef11bfcb0
  error 4 in libgtk-x11-2.0.so.0.2400.30[7ff51001b000+43e000]

  I'm using a fresh install of Xubuntu 16.04 with nvidia 361.42 driver
  (available from the Additional Drivers tab). In that same tab, I also
  have enabled Processor microcode firmware for Intel CPUs. Terminal
  tells me Gimp version is 2.8.16-1ubuntu1

  I'm not very experienced with bug reporting and not sure what other
  information I need to supply. Gimp was absolutely rock solid on this
  machine with 15.10, so it may be a Xubuntu issue.

  Hope someone can take a look at this. Thanks.

To manage notifications about this bug go to:
https://bugs.launchpad.net/gtk/+bug/1576424/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to