The hwe stacks are created for purpose, so with 16.04.2 being almost out
I doubt this will be backported to non-hwe. Closing as fixed.

** Changed in: xserver-xorg-video-r128 (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xserver-xorg-video-r128 in Ubuntu.
https://bugs.launchpad.net/bugs/1664531

Title:
  xf86-video-r128 6.10.0 breaks rage 128 pro ultra

Status in xserver-xorg-video-r128 package in Ubuntu:
  Fix Released

Bug description:
  I ran into this bug on Xenial LTS which left xorg unable to start.

  It was fixed upstream in 6.10.1, so when I installed the the hwe
  package, it worked just fine. Perhaps LTS needs to be updated to the
  hwe?

  This bug is particularly frustrating because xorg fails without an
  obvious problem. There wasn't much to search for, so it took me days
  before I happened across the bug report at netbsd.org. I'd say that
  makes for an even more compelling case to update the LTS package.

  What happens is that xorg immediately exits. Xorg.0.log shows a normal
  startup, finds a bunch of modes, and then exits with the message,
  "(EE) Screen(s) found, but none have a usable configuration." without
  any indication of modes being rejected.

  I tried all sorts of workarounds vaguely related to mode detection,
  but none of them would work.

  Here's the mailing list discussion surrounding the bug. The Xorg.0.log
  excerpts in the discussion were exactly what I saw here, so I'll just
  refer to that: http://gnats.netbsd.org/50599

  Let me know if I need to use ubuntu-bug xserver-xorg-video-r128

  Failed: xserver-xorg-video-r128_6.10.0-1build2
  Works:  xserver-xorg-video-r128-hwe-16.04_6.10.1-1~16.04.1

  lsb_release -rd:
  Description:    Ubuntu 16.04.2 LTS
  Release:        16.04

  
  lspci -kv:
  03:02.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] 
Rage128 [Xpert 128 PCI] (prog-if 00 [VGA controller])
          Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Xpert 128
          Flags: bus master, stepping, medium devsel, latency 64, IRQ 16
          Memory at f8000000 (32-bit, prefetchable) [size=64M]
          I/O ports at d800 [size=256]
          Memory at fe6fc000 (32-bit, non-prefetchable) [size=16K]
          Expansion ROM at fe6c0000 [disabled] [size=128K]
          Capabilities: [5c] Power Management version 2
          Kernel modules: aty128fb

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-r128/+bug/1664531/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to