Responses to your previous questions:
1) It may take a bit of time before I can make the tests with the current 
Ubuntu version. And, I fear that such tests might not be reliable: after the 
temporary use of the NVidia driver I could use the "nouveau" driver for some 
time even without the special boot parameter "nouveau.config=NvMSI=0" - only 
after some months, new freezes occurred. I have the feeling that the problem 
(now) arises non-deterministically -- likely dependent on environment factors 
such as temperature and/or humidity.
While freezes are now rather rare for me, I often observe that the top bars of 
my windows (usually black) are drawn in an irregular black/white pattern 
(similar to the freeze pattern) when I move the mouse pointer over the bar. I 
have the feeling that this is related to the freeze problem.

2) I had no crashes in Ubuntu 12.04 - without any kernel boot
parameters. But, I am not sure that under 12.04, I was already using the
"nouveau" driver. Earlier Ubuntu versions have been using another
standard driver for NVidia cards (likely "nv") and I can no longer
remember which Ubuntu version has switched to "nouveau". I myself did
not actively switch to "nouveau".

3) I could use the NVidia driver for some time under Ubuntu 16.04. But,
its use is unstable in the sense that an Ubuntu update can render it
dysfunctional (apparently, a post installation step has problems to
properly integrate the NVidia driver) and it is very nasty to fix things
up afterwards (I must use a different driver and then reinstall the
NVidia driver via "system administration"). I therefore switched back to
"nouveau".

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1649566

Title:
  [GeForce 7025 / nForce 630a] System freeze

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  Yesterday, I upgraded from Ubuntu 12.04 via 14.04 to 16.04. From 14.04
  on, I was unable to graphically log in. A few seconds after the login
  (varying between 1 and 10 s), the screen changed to a pattern with
  dense white stripes on the violet/red background, and X froze (no
  reaction to mouse or keyboard). The latest messages in
  "/var/log/syslog" each time showed varying "nouveau E" problems, e.g.
  "unrecognized interupt", "PFIFO", or "PBUS" problems such as e.g.:
  "nouveau E[    PBUS][0000:00:0d.0] MMIO write of 0x01f70001 FAULT at
  0x00b010" (values and addresses varying).

  Usually, the freeze happens when e.g. "firefox" is started (which
  happens in my context automatically after a graphical login). In my
  case, the NVidia driver could not be started (I did not investigate
  why). Using boot parameter "nouveau.config=NvMSI=0" made the graphical
  login successful again.

  Today, I wanted to report the bug with "ubuntu-bug". However, during
  the collection of the system information, the error happened again
  (despite the "nouveau.config" boot parameter).

  Syslog gives:
  ...
  Dec 13 11:12:01 localhost CRON[5230]: (root) CMD (   test -x 
/etc/cron.daily/popularity-contest && /etc/cron.daily/popularity-contest 
--crond)
  Dec 13 11:14:16 localhost kernel: [ 6889.138599] nouveau E[    
PBUS][0000:00:0d.0] MMIO write of 0x07920001 FAULT at 0x00b020
  Dec 13 11:14:16 localhost kernel: [ 6889.140532] nouveau E[    
PBUS][0000:00:0d.0] MMIO write of 0x07920001 FAULT at 0x00b020
  Dec 13 11:14:59 localhost dbus[795]: [system] Activating service 
name='com.ubuntu.SoftwareProperties' (using servicehelper)
  Dec 13 11:14:59 localhost dbus[795]: [system] Successfully activated service 
'com.ubuntu.SoftwareProperties'
  Dec 13 11:15:01 localhost CRON[5285]: (root) CMD (command -v debian-sa1 > 
/dev/null && debian-sa1 1 1)
  Dec 13 11:17:01 localhost CRON[5303]: (root) CMD (   cd / && run-parts 
--report /etc/cron.hourly)
  Dec 13 11:20:01 localhost CRON[5327]: (smmsp) CMD (test -x 
/etc/init.d/sendmail && test -x /usr/share/sendmail/sendmail && test -x 
/usr/lib/sm.bin/sendmail && /usr/share/sendmail/sendmail cron-msp)
  Dec 13 11:22:20 localhost kernel: [ 7372.621357] nouveau E[    
PBUS][0000:00:0d.0] MMIO write of 0x00000000 FAULT at 0x00b020
  Dec 13 11:25:01 localhost CRON[5580]: (root) CMD (command -v debian-sa1 > 
/dev/null && debian-sa1 1 1)
  Dec 13 11:35:01 localhost CRON[5651]: (root) CMD (command -v debian-sa1 > 
/dev/null && debian-sa1 1 1)
  Dec 13 11:38:02 localhost gnome-session[2248]: Gtk-Message: GtkDialog mapped 
without a transient parent. This is discouraged.
  Dec 13 11:39:01 localhost CRON[5723]: (root) CMD (  [ -x 
/usr/lib/php5/maxlifetime ] && [ -x /usr/lib/php5/sessionclean ] && [ -d 
/var/lib/php5 ] && /usr/lib/php5/sessionclean /var/lib/php5 
$(/usr/lib/php5/maxlifetime))
  Dec 13 11:39:01 localhost CRON[5722]: (root) CMD (  [ -x 
/usr/lib/php/sessionclean ] && /usr/lib/php/sessionclean)
  Dec 13 11:39:46 localhost gnome-session[2248]: Gtk-Message: GtkDialog mapped 
without a transient parent. This is discouraged.

  At this point, I had to reset the computer.

  ---
  ApportVersion: 2.20.1-0ubuntu2.15
  Architecture: i386
  CompizPlugins: 
[core,bailer,detection,composite,opengl,compiztoolbox,decor,move,resize,snap,place,grid,vpswitch,gnomecompat,mousepoll,imgpng,session,regex,animation,unitymtgrabhandles,workarounds,wall,fade,expo,ezoom,scale,unityshell]
  DistUpgraded: 2016-12-12 17:25:47,166 DEBUG Running PostInstallScript: 
'./xorg_fix_proprietary.py'
  DistroCodename: xenial
  DistroRelease: Ubuntu 16.04
  DistroVariant: ubuntu
  DpkgLog:

  ExtraDebuggingInterest: Yes
  GraphicsCard:
   NVIDIA Corporation C61 [GeForce 7025 / nForce 630a] [10de:03d6] (rev a2) 
(prog-if 00 [VGA controller])
     Subsystem: ASRock Incorporation C61 [GeForce 7025 / nForce 630a] 
[1849:03d6]
  InstallationDate: Installed on 2013-01-21 (1838 days ago)
  InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release i386 
(20120817.3)
  Lsusb:
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
  MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
  Package: xorg 1:7.7+13ubuntu3
  PackageArchitecture: i386
  ProcEnviron:
   TERM=linux
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=de_DE.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-112-generic 
root=UUID=9c03cebc-9cba-47bc-9974-5c236a34906e ro nouveau.config=NvMSI=0
  ProcVersionSignature: Ubuntu 4.4.0-112.135-generic 4.4.98
  Tags:  xenial ubuntu
  Uname: Linux 4.4.0-112-generic i686
  UpgradeStatus: Upgraded to xenial on 2016-12-12 (416 days ago)
  UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
  _MarkForUpload: True
  dmi.bios.date: 05/27/2010
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: P1.30
  dmi.board.name: N68-S3 UCC
  dmi.board.vendor: ASRock
  dmi.chassis.asset.tag: To Be Filled By O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: To Be Filled By O.E.M.
  dmi.chassis.version: To Be Filled By O.E.M.
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrP1.30:bd05/27/2010:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnN68-S3UCC:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
  dmi.product.name: To Be Filled By O.E.M.
  dmi.product.version: To Be Filled By O.E.M.
  dmi.sys.vendor: To Be Filled By O.E.M.
  version.compiz: compiz 1:0.9.12.2+16.04.20160823-0ubuntu1
  version.libdrm2: libdrm2 2.4.83-1~16.04.1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.2.4-0ubuntu1~16.04.4
  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.2.4-0ubuntu1~16.04.4
  version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.7
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.7.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20160325-1ubuntu1.2
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 
1:1.0.12-1build2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1649566/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to