George, thank you for reporting this and helping make Ubuntu better.

1) Regarding the version of the nvidia drivers you attempted to use, it
appears you are using an upstream or 3rd party version. Could you please
mention where you obtained the driver from?

2) Could you please install a supported version of the nvidia driver
found at https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia and
advise to the results?

3) Do you have this issue if you don't install a proprietary nvidia
driver?

4) To advise, when attaching logs, please don't snip/grep/cut logs.
Attach logs in their entirety from the first entry of a boot to when the
issue is reproducible. Developers can't work with snips.

** Tags added: latest-bios-1.13

** Changed in: xorg (Ubuntu)
   Importance: Undecided => Low

** Changed in: xorg (Ubuntu)
       Status: New => Incomplete

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.
https://bugs.launchpad.net/bugs/1748656

Title:
  Black Screen of Death after logging into Ubuntu Bionic: "Failed to
  acquire modesetting permission"

Status in xorg package in Ubuntu:
  Incomplete

Bug description:
  **Specs:** Ubuntu Bionic; NVidia GTX 1070 w/`nvidia-387` drivers.

  **Problem:** After installing a new GTX 1070 and installing
  `nvidia-387`, I get a black screen of death AFTER logging into Ubuntu
  (i.e., the login screen shows up just fine). I'm not even able to
  access other TTYs (the error logs below were retrieved via SSH).

  **/var/log/Xorg.0.log** There doesn't seem to be anything problematic
  in this file.

  **/var/log/Xorg.1.log** The problematic message seems to be:

      [    26.455] (EE) NVIDIA(GPU-0): Failed to acquire modesetting permission.
      [    26.455] (EE) NVIDIA(0): Failing initialization of X screen 0
      [    26.455] (II) UnloadModule: "nvidia"
      [    26.455] (II) UnloadSubModule: "wfb"
      [    26.455] (II) UnloadSubModule: "fb"
      [    26.455] (EE) Screen(s) found, but none have a usable configuration.
      [    26.455] (EE) 
      Fatal server error:
      [    26.455] (EE) no screens found(EE) 
      [    26.455] (EE) 
      Please consult the The X.Org Foundation support 
              at http://wiki.x.org
      for help. 
      [    26.455] (EE) Please also check the log file at "/var/log/Xorg.1.log" 
for additional information.
      [    26.455] (EE) 
      [    26.457] (EE) Server terminated with error (1). Closing log file.

  **Conf files.** Here are my conf files:

      $ cd /usr/share/X11
      $ find . -name "*.conf"
      ./xorg.conf.d/glamoregl.conf
      ./xorg.conf.d/10-amdgpu.conf
      ./xorg.conf.d/40-libinput.conf
      ./xorg.conf.d/50-nvidia-drm-outputclass.conf
      ./xorg.conf.d/50-nvidia-drm-outputclass.conf/nvidia-drm-outputclass.conf
      ./xorg.conf.d/10-quirks.conf
      ./xorg.conf.d/10-radeon.conf
      ./xorg.conf.d/70-wacom.conf

  I tried deleting all of these except for the nvidia one and rebooting,
  and the error persists. In addition, I tried deleting all of them and
  generating a new one via `sudo X -configure` but get

      $ cd /usr/share/X11$ 
      $ sudo pkill X && sudo X -configure                                      
      _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
      _XSERVTransMakeAllCOTSServerListeners: server already running
      (EE) 
      Fatal server error:
      (EE) Cannot establish any listening sockets - Make sure an X server isn't 
already running(EE) 
      (EE) 
      Please consult the The X.Org Foundation support 
              at http://wiki.x.org
      for help. 
      (EE) Please also check the log file at "/var/log/Xorg.0.log" for 
additional information.
      (EE) 
      (EE) Server terminated with error (1). Closing log file.

  **kms.** Finally, in case relevant:

      $ lsmod | grep kms
      drm_kms_helper        167936  1 nvidia_drm
      syscopyarea            16384  1 drm_kms_helper
      sysfillrect            16384  1 drm_kms_helper
      sysimgblt              16384  1 drm_kms_helper
      fb_sys_fops            16384  1 drm_kms_helper
      drm                   356352  6 nvidia_drm,drm_kms_helper

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg (not installed)
  ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
  Uname: Linux 4.13.0-25-generic x86_64
  NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
  .proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: 
'/proc/driver/nvidia/gpus/0000:01:00.0'
  .proc.driver.nvidia.registry: Binary: ""
  .proc.driver.nvidia.version:
   NVRM version: NVIDIA UNIX x86_64 Kernel Module  387.34  Tue Nov 21 03:09:00 
PST 2017
   GCC version:  gcc version 7.2.0 (Ubuntu 7.2.0-18ubuntu2)
  .proc.driver.nvidia.warnings.fbdev:
   Your system is not currently configured to drive a VGA console
   on the primary VGA device. The NVIDIA Linux graphics driver
   requires the use of a text-mode VGA console. Use of other console
   drivers including, but not limited to, vesafb, may result in
   corruption and stability problems, and is not supported.
  ApportVersion: 2.20.8-0ubuntu6
  Architecture: amd64
  CompizPlugins: No value set for 
`/apps/compiz-1/general/screen0/options/active_plugins'
  Date: Sat Feb 10 13:14:48 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  DkmsStatus:
   bbswitch, 0.8, 4.13.0-25-generic, x86_64: installed
   nvidia-387, 387.34, 4.13.0-25-generic, x86_64: installed
  ExtraDebuggingInterest: I just need to know a workaround
  GraphicsCard:
   NVIDIA Corporation GP104 [GeForce GTX 1070] [10de:1b81] (rev a1) (prog-if 00 
[VGA controller])
     Subsystem: eVga.com. Corp. GP104 [GeForce GTX 1070] [3842:6276]
  InstallationDate: Installed on 2017-11-02 (100 days ago)
  InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
  MachineType: MSI MS-7917
  ProcEnviron:
   TERM=eterm-color
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-25-generic.efi.signed 
root=UUID=faffd739-c6ab-44ee-8c8c-4aa2ac8b7439 ro quiet splash vt.handoff=1
  SourcePackage: xorg
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 02/16/2016
  dmi.bios.vendor: American Megatrends Inc.
  dmi.bios.version: V1.13
  dmi.board.asset.tag: To be filled by O.E.M.
  dmi.board.name: Z97 GAMING 5 (MS-7917)
  dmi.board.vendor: MSI
  dmi.board.version: 1.0
  dmi.chassis.asset.tag: To be filled by O.E.M.
  dmi.chassis.type: 3
  dmi.chassis.vendor: MSI
  dmi.chassis.version: 1.0
  dmi.modalias: 
dmi:bvnAmericanMegatrendsInc.:bvrV1.13:bd02/16/2016:svnMSI:pnMS-7917:pvr1.0:rvnMSI:rnZ97GAMING5(MS-7917):rvr1.0:cvnMSI:ct3:cvr1.0:
  dmi.product.family: To be filled by O.E.M.
  dmi.product.name: MS-7917
  dmi.product.version: 1.0
  dmi.sys.vendor: MSI
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.89-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-2
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-2
  version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.5-0ubuntu2
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
2:2.99.917+git20171229-1
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1748656/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to