One month ago I upgraded Virtualbox from 5.2.4 to 5.2.6. While I was upgrading 
Vbox Guest Additions in my VMs to 5.2.6, I detected that that 5.2.6 Guest 
additions introduced a serious boot/login problem for all my VMs. So as a 
work-around I kept all my VMs at Guest Additions 5.2.4. I reported that problem 
to Oracle here: 
In that long discussion between various persons about the problem, other 
work-arounds had been proposed too. I detected yesterday that other people used 
"beta" 5.2.7 to solve the problem.

We are dealing with 2 separate problems:
- one is the boot/login problem of the Vbox Guest Additions 5.2.6, reported to 
Oracle one month ago. That problem occurs in all my VMs and all my distros. My 
work-around was stick to Guest Additions 5.2.4.
- the other is the window maximising problem with Vbox Guest Additions 5.2.4 
reported to you only occurring in Ubuntu Gnome 17.10 and 18.04. Work-arounds 
are stop using 3D acceleration, if you do not need the performance improvement 
of that 3D acceleration. If you need the performance improvement of that 3D 
acceleration use any other distro, since the problem only occurs in Ubuntu 

I detected today that Vbox Guest Additions 5.2.7 was available. So I thought 
maybe I get lucky and it also solves the window maximising problem, so I tried 
it. It did not solve that problem. All the time my Host remained at Vbox 5.2.6.

I removed virtualbox-guest-x11. I did not realise, that it was the Ubuntu 
version of Vbox Guest Additions. I always install Vbox Guest Additions through 
its ISO file, since it then also nicely removes the currently installed 
version. In general Ubuntu is a full release behind with respect to Virtualbox. 
Ubuntu's current Vbox release for Ubuntu 17.10 is 5.1.30, while Ubuntu 18.04 
uses Vbox 5.2.6. I tried your advice at Ubuntu 18.04. That installed Vbox Guest 
Additions 5.2.6, so it is completely understandable, that the login problem 
reported to Oracle a month ago reappeared. 

As Ubuntu you have learned I think four things from this confusion:
- Avoid Vbox Guest Additions 5.2.6 in Ubuntu 18.04. Stick to Vbox 5.2.4 or push 
Oracle for 5.2.8.
- I would talk to Oracle about the quality of their regression testing in the 
light of your new philosophy with respect to more integration of the Vbox Guest 
Additions as reported by e.g. OMG Ubuntu. 
- Maybe you should only update the host versions in your repository and leave 
the update of the Guest to the current Oracle mechanisms. They store the 
correct guest ISO file somewhere in the Linux file system of the host and make 
it available to the guest through the Host devices menu "Insert Guest Additions 
CD image". They warn you about outdated guests through notification, but leave 
the upgrade decision to you. I love that mechanism.
- You still have a separate "windows maximising" problem in Ubuntu Gnome.

I will download the 5.1.30 Guest Additions ISO file and try that one in
Ubuntu 17.10.

** Bug watch added: Virtualbox Trac #17463

You received this bug notification because you are a member of Desktop
Packages, which is subscribed to xorg in Ubuntu.

  Xorg freeze

Status in xorg package in Ubuntu:

Bug description:
  Host: Ubuntu 18.04, Virtualbox 5.2.6
  Guest: Ubuntu GNOME 17.10 and 18.04

  The problem is the guest's screen almost freezes completely as soon as
  I maximise any window in the guest. Any mouse click takes 10-60
  seconds before the system reacts to it.

  Windows 7 and 10 work without any problem.

  WORKAROUND: Disable 3D acceleration.

  WORKAROUND: Use as a guest Ubuntu Mate or Xubuntu.

  ProblemType: Bug
  DistroRelease: Ubuntu 18.04
  Package: xorg 1:7.7+19ubuntu4
  ProcVersionSignature: Ubuntu 4.13.0-32.35-generic 4.13.13
  Uname: Linux 4.13.0-32-generic x86_64
  ApportVersion: 2.20.8-0ubuntu8
  Architecture: amd64
  CompositorRunning: None
  CurrentDesktop: ubuntu:GNOME
  Date: Sun Feb 11 06:31:52 2018
  DistUpgraded: Fresh install
  DistroCodename: bionic
  DistroVariant: ubuntu
  ExtraDebuggingInterest: Yes
  GpuHangFrequency: Continuously
  GpuHangReproducibility: Yes, I can easily reproduce it
  GpuHangStarted: Immediately after installing this version of Ubuntu
  GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter 
[80ee:beef] (prog-if 00 [VGA controller])
  InstallationDate: Installed on 2017-12-22 (50 days ago)
  InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171219)
   Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  MachineType: innotek GmbH VirtualBox
  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.13.0-32-generic 
root=UUID=f3311827-9a0c-490d-a707-d4d037152c4d ro quiet splash
  Renderer: Software
  SourcePackage: xorg
  Symptom: display
  Title: Xorg freeze
  UpgradeStatus: No upgrade log present (probably fresh install)
  dmi.bios.date: 12/01/2006
  dmi.bios.vendor: innotek GmbH
  dmi.bios.version: VirtualBox
  dmi.board.name: VirtualBox
  dmi.board.vendor: Oracle Corporation
  dmi.board.version: 1.2
  dmi.chassis.type: 1
  dmi.chassis.vendor: Oracle Corporation
  dmi.product.family: Virtual Machine
  dmi.product.name: VirtualBox
  dmi.product.version: 1.2
  dmi.sys.vendor: innotek GmbH
  version.compiz: compiz N/A
  version.libdrm2: libdrm2 2.4.89-1
  version.libgl1-mesa-dri: libgl1-mesa-dri 17.3.3-0ubuntu1
  version.libgl1-mesa-glx: libgl1-mesa-glx 17.3.3-0ubuntu1
  version.xserver-xorg-core: xserver-xorg-core 2:1.19.6-1ubuntu1
  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev N/A
  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.10.0-1
  version.xserver-xorg-video-intel: xserver-xorg-video-intel 
  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.15-2

To manage notifications about this bug go to:

Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to