After logging into to wayland and then back into X11, a wayland socket
is lingering:

$ ls -l /run/user/`id -u`/wayland*
srwxrwxr-x 1 osomon osomon 0 févr. 14 16:54 /run/user/1000/wayland-0
-rw-rw---- 1 osomon osomon 0 févr. 14 16:54 /run/user/1000/wayland-0.lock

Removing those two files "fixes" the issue.

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to libreoffice in Ubuntu.
https://bugs.launchpad.net/bugs/1749484

Title:
  [snap] fail to launch after logging in to a wayland session then back
  into an X11 session

Status in libreoffice package in Ubuntu:
  New

Bug description:
  My default session is "Ubuntu" (/usr/share/xsessions/ubuntu.desktop).
  If I log out, then log in to "Ubuntu on Wayland", then out again and
  in to "Ubuntu" again (so I'm back to my initial session), the
  libreoffice snap fails to start:

  osomon@bribon:~$ /snap/bin/libreoffice
  /snap/libreoffice/49/lib/libreoffice/program/soffice.bin X11 error: Can't 
open display:
     Set DISPLAY environment variable, use -display option
     or check permissions of your X-Server
     (See "man X" resp. "man xhost" for details)

  osomon@bribon:~$ env | grep DISPLAY
  DISPLAY=:0

  Rebooting my machine "fixes" the issue.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1749484/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to