Why is this marked as "Fix Released"?

ED25519 keys don't work.
https://bugzilla.gnome.org/show_bug.cgi?id=723274

** Bug watch added: GNOME Bug Tracker #723274
   https://bugzilla.gnome.org/show_bug.cgi?id=723274

-- 
You received this bug notification because you are a member of Desktop
Packages, which is subscribed to gnome-keyring in Ubuntu.
https://bugs.launchpad.net/bugs/771272

Title:
  gnome-keyring doesn't support ecdsa or ed25519 keys

Status in GNOME Keyring:
  Fix Released
Status in gnome-keyring package in Ubuntu:
  Triaged
Status in gnome-keyring package in Debian:
  Fix Released

Bug description:
  Binary package hint: gnome-keyring

  I'm not sure I have described it correctly in the summary, but this is what 
happens:
  I run ssh-add in a new terminal and enter my passphrase, which is the same 
for my DSA and ECDSA key: the DSA identity is added, but the ECDSA gets the 
"Error reading response length from authentication socket. Could not add 
identity: /home/claudio/.ssh/id_ecdsa" error.
  I run ssh-agent, copy and paste the output in the terminal and re-run 
ssh-add. Both identities are correctly added:
  ============================================================================
  claudio@Chuck:~$ ssh-add 
  Enter passphrase for /home/claudio/.ssh/id_dsa: 
  Identity added: /home/claudio/.ssh/id_dsa (/home/claudio/.ssh/id_dsa)
  Error reading response length from authentication socket.
  Could not add identity: /home/claudio/.ssh/id_ecdsa
  claudio@Chuck:~$ ssh-agent 
  SSH_AUTH_SOCK=/tmp/ssh-szGWMUbE3916/agent.3916; export SSH_AUTH_SOCK;
  SSH_AGENT_PID=3917; export SSH_AGENT_PID;
  echo Agent pid 3917;
  claudio@Chuck:~$ SSH_AUTH_SOCK=/tmp/ssh-szGWMUbE3916/agent.3916; export 
SSH_AUTH_SOCK;
  claudio@Chuck:~$ SSH_AGENT_PID=3917; export SSH_AGENT_PID;
  claudio@Chuck:~$ echo Agent pid 3917;
  Agent pid 3917
  claudio@Chuck:~$ ssh-add 
  Enter passphrase for /home/claudio/.ssh/id_dsa: 
  Identity added: /home/claudio/.ssh/id_dsa (/home/claudio/.ssh/id_dsa)
  Identity added: /home/claudio/.ssh/id_ecdsa (/home/claudio/.ssh/id_ecdsa)
  ============================================================================
  Here is the content of my ~/.ssh/

  claudio@Chuck:~$ ls -l .ssh
  total 32
  -rw-r--r-- 1 claudio claudio  726 2011-04-15 23:34 config
  -r-------- 1 claudio claudio  751 2011-04-05 10:35 id_dsa
  -rw-r--r-- 1 claudio claudio  603 2011-04-05 10:34 id_dsa.pub
  -r-------- 1 claudio claudio  444 2011-04-05 10:29 id_ecdsa
  -rw-r--r-- 1 claudio claudio  267 2011-04-05 10:23 id_ecdsa.pub
  -rw------- 1 claudio claudio 6402 2011-04-19 18:04 known_hosts
  -rw-r--r-- 1 claudio claudio 2760 2011-04-06 17:05 known_hosts.old

  ProblemType: Bug
  DistroRelease: Ubuntu 11.04
  Package: gnome-keyring 2.92.92.is.2.32.1-0ubuntu2
  ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
  Uname: Linux 2.6.38-8-generic x86_64
  NonfreeKernelModules: nvidia
  Architecture: amd64
  Date: Tue Apr 26 16:27:02 2011
  ProcEnviron:
   LANGUAGE=en_US:en
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: gnome-keyring
  UpgradeStatus: Upgraded to natty on 2011-04-03 (23 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/gnome-keyring/+bug/771272/+subscriptions

-- 
Mailing list: https://launchpad.net/~desktop-packages
Post to     : desktop-packages@lists.launchpad.net
Unsubscribe : https://launchpad.net/~desktop-packages
More help   : https://help.launchpad.net/ListHelp

Reply via email to